A key atribute appeared in all my notes


(Roberto Moreira) #1

I imported an OPML file from Ominoutliner with a column. This column became a key atribute in all notes in the document!

If a create a new note, this key atribute appears.

I tried to select all notes and hide it, but I think I have too many notes. It doesn’t work.

Any suggestions?

Thanks in advance.

Roberto


(Paul Walters) #2

It’s possible that all the notes in your document have the same Prototype, and that prototype has that attribute defined as a KA, so I would check that first. It might be as simple as removing that attribute from the prototype’s KA list.

If you no longer want that user attribute, then deleting it in the attribute inspector will delete it everywhere.


(Roberto Moreira) #3

Paul, thanks for the quick response.

I deleted it, but it still appears with the name in gray now.

And it is a KA in all notes that have no prototype.

It appears the default appearance of notes has some trouble.

I created a new document and copied everything there. Sometimes is better to start again! But I discovered that my aliases will be lost… It’s not a big deal, but would I lose something else?


(Paul Walters) #4

I don’t know the name of the attribute in question, but let’s say it is “MyAttribute”. You can use an agent with the query

$KeyAttributes.icontains("MyAttribute");

and with this action

$KeyAttributes=$KeyAttributes.replace("MyAttribute","");

This agent will find all cases where KeyAttributes contains the attribute in question, and remove the attribute from KeyAttributes. The other KeyAttributes settings will remain intact.

(After running once, and performing the action on all the query results, the agent should no longer return query results. You can delete the agent at that point.)


How do you remove a Tag from and existing set of tags within a note?
(Roberto Moreira) #5

It worked! thanks a lot!


(Roberto Moreira) #6

Paul,

I still have a problem. When I create a new note it has this “default” KA. Then the agent you suggested hides it. But I’m curious about that. What do you think can generate this kind of behavior?


(eastgate) #7

Perhaps you changed the default value of $KeyAttributes?


(Roberto Moreira) #8

I think so, but how I can fix it?


(Paul Walters) #9

If this is a user attribute you do not want to use at all, you can go to the Document Inspector > User attributes tab and delete the attribute from our document.

We don’t know enough about what you are doing.

Notes do not get key attributes unless you configure them explicitly for individual notes, or unless the note is inheriting its key attributes from a prototype, or something is assigning key attributes – something such as an agent, or a stamp, or an on-add action, or an action in Attribute Browser, or a smart adornment.

Lots of possibilities, but we don’t know which case applies to you.


(eastgate) #10

If you changed the default value of KeyAttributes in the System Attributes pane of the Document inspector, as suggested above, simply go back to the System Attributes pane and change the default value back to the empty string.


(Roberto Moreira) #11

Paul and Mark,

Thank you!

Just for the record. I dropped in Tinderbox an omnioutliner file with a column “pgs” and this created a KA pgs as default for all notes.

Best,


(Paul Walters) #12

That is expected behavior, for the imported notes.