How to disable automatic Composites?


(John Miller) #1

Composites look very useful, but IMHO they should NOT be automatic, but rather more like a Group operation, i.e., select the things you want to group and do that operation to them. In fact there should be a shortcut key for both creating and breaking a composite (could be two shortcuts or a toggle). As it is now, composites happen when I don’t want them to and I have to go to the menus to break the composite. That’s esp. frustrating when opening an old tbx file and everything that was happily close together is now automatically made a composite - and I didn’t even move anything.

– jdm


(Paul Walters) #2

A document-wide preference would be useful.

For now, a couple of approaches:

  1. Create a prototype (say, “noComposites”) whose sole setting is to make $NeverComposite a key attribute with the value true. The make this “noComposites” prototype the for all other prototypes. Prototype inheritance will make sure that the $NeverComposite=true setting will ripple through your document.
  2. Alternatively, create a stamp whose action is $NeverComposite=true and apply to all your notes. The problem here is you need to do that over and over.

You can also consider putting all your notes in the same parent container and setting the OnAdd action for that container to $NeverComposite=true.

Not completely what you want, but actions can help.


(John Miller) #3

Hey, thanks Paul. I like the noComposites prototype workaround for now.

– jdm


(eastgate) #4

A document-wide preference would be useful.

Easily done. In the System Attribute inspector, change the default value of $NeverComposite t0 true.

Also, to break up a composite, just ⌘-drag a note out of the composite.


(Paul Walters) #5

Doh. Of course! Best idea of all. :clap::clap: