Link park pop up problem


(Yuval Gavish) #1
  1. I select some text in $Text of “note 1”
  2. press [Cmd]+[Shift]+[L]
  3. use autocomplete to select the right destination note
  4. choose link type, and press “create link”

the link is created (it’s there in “Browse Links” and “Roadmap”), but the anchor text in “note 1” is not highlighted and not clickable, and ofcorse, not taking me to the destination.

any idea?


(Paul Walters) #2

Just checked this informally in a few documents and I cannot reproduce. I.e., the links are created, and once created they are highlight (default blue) and clickable.

Did you by any chance change Text Link Color in the Text tab of Document Settings?

When you hover over the link does the pointer change to the hand pointer indicating the link is clickable?

Were you in the Text pane when you tried to see the link?

Does this happen in every file or just one file?


(Yuval Gavish) #3

Thanks for your help Paul,

  1. No
  2. No
  3. Yes
  4. Yes

(Brian Crane) #4

I can reproduce this.

However, if I leave the source note by clicking on another one and then return to it, the in-text link is properly highlighted and clickable.

Setting “After Linking:” on the Map tab in Document Preferences to “select destination” makes the move away automatic. Cmd-’ then brings you back to the source note with a working link.


(Yuval Gavish) #5

Thanks, Brian,
That works like a charm!
Thanks again


(Mark Anderson) #6

I can replicate too. This condition occurs if the preference for action post linking is set to the non-default value of ‘select source’. If I then click out of the note and back in again, the link is there. This is a refresh issue. Basically, I believe Tinderbox needs to ensure a refresh of $Text (saving resetting scroll state too?) occurs each time a link is added. At least, it should do this if the preference is set to ‘select source’. pinging @eastgate for reference.


(Yuval Gavish) #7

Excellent, Mark, thanks a lot