Login blues - Text windows and spelling


(Mariano Iannuzzi) #1

Hello,

I am experiencing some oddities that I did not notice before, so I am unsure if this is exclusive to tbx 7.3 or a general behavior.

  1. When I open a TBX file, the note’s Text Windows (all of them!) open simultaneously, which is a bit annoying. The behavior is recurrent. I tried closing all Text Windows, saving the document, and restarting TBX, but the same issues persist.

  2. I also noticed that the option “check spelling while typing” and “check grammar while typing” return to their unselected default value after closing TBX. I have to select them every time manually. Is it possible make the change to these options persistent?

Thank you very much!

BTW, I am using TBX on an iMac running macOS Sierra.

M


(Mark Anderson) #3
  1. This sounds similar to an issue recently reported elsewhere and I believe under current investigation. Please contact technical support directly with your detail on this.

  2. “check spelling while typing” is on by default (it’s actually a default doc setting). Hm. http://www.acrobatfaq.com/atbref7/index/PreferencesDocumentSetti/DocumentSettings/General/Checkspellingasyoutype.html indicates it’s off by default. But, testing v7.3.0 with fresh preferences the setting is seeded as on (I suspect my notes are wrong and the default setting flipped as of v6+). Anyway, go to your doc settings’ General and tick the spelling box and this setting should persist. At present there is no persistent option for th grammar setting.

A lot of these spelling/substitution options that are part of the underlying Apple frameworks only hold a non-default for as long as the doc is open. That’s fine for TextEdit and the like but here each time a note loses focus these settings return to default except for a few (e.g. for smart quotes). If you need a persistent grammar setting please email a feature request into tech support.


(Mark Anderson) #4

TEsting further I’m pretty sure my note on this setting was wrong, as it seems to have changed in v6+. I’ve updated the aTbref page as a result. I still don’t know why it’s not behaving for @marianoiannuzzi though.


(James Fallows) #5

Yes, can confirm this – my version is that any text window that has ever been opened will spring back to life when you reopen the file. But also have heard from Eastgate support that they’re aware of the bug and will have a fix on the way.


(Mariano Iannuzzi) #6

@mwra thank you very much, as usual. A few observations:

  1. Spell checker: I have the “Check Spelling as you Type” option selected in the “Documents Properties” window:

A you can see, “Check spelling while typing” in the “Edit” menu is not checked when typing a new note:

I also noticed that this behavior is only true when typing the Note’s Title in Map/Outline view. Selecting the Text field, however, indicates that “Check spelling while typing” is on, which matches the Doc’s preferences.

I think it would be good if the “Check spelling while typing” option in the “Edit” menu would remember whether the user selected it for the entire document. Same with the grammar checker in “Edit.” Scrivener, Ulysses, etc. make the user-defined choice persistent so that the option is selected after closing/reopening the document.

  1. I can also confirm @JFallows observation. In the attached tbx file, I opened “Note 1’s” text window but I typed “Note 2” text directly in the Text Field.

Testing.tbx (54.1 KB)

Thank you very much!

M


(Mark Anderson) #7

Thanks for the feedback. Do make sure you send this to tech support so it gets recorded (here, we’re just fellow users).