New Notes Are Squashed on the Map


(Kent Wayland) #1

Hi Folks,

I was all excited to show off Tinderbox to my class yesterday, but I had a snafu that I cannot figure out. Whenever I would create a new note on the map, whether by hitting return or by double-clicking, the note would show up as a totally squashed note, something like | instead of a rectangle. (See the image.) I have a hard time even selecting them. When I started seeing this, my document setting for notes was for them to “expand proportionately,” when the note name is long, but even when I returned that to “do nothing,” the problem persisted. A restart of Tinderbox did not help. Is this a bug? Am I missing something obvious? Any ideas?

Any help would be much appreciated.

Thanks!

Kent Wayland


(Paul Walters) #2

Could you post here a sample file (with sample data) that has this behavior?

It appears your notes are sitting on an adornment, but looking at the file might be helpful.


(Kent Wayland) #3

Hi Paul,

Thanks for your response. The notes that were not on the adornment were the same. I tried a new document, and it worked just fine, so there must be something going on in that file. I hope that file isn’t corrupted …


(Paul Walters) #4

Check the value of the Width attribute. Something (an agent or rule?) is setting Width incorrectly.


(Kent Wayland) #5

That was it! For some reason the default width got set to 0, and I couldn’t change it.

I knew it would be something simple.

Thanks!


(Mark Anderson) #6

If you’re changing it and it’s changing back to zero, a mistake in a rule or agent action is a likely cause. If you’re unsure how to set $Width or $Height except by dragging the map icon for the note, use the Quickstamp or the Get Info/attributes tab to edit the attribute values.