Turning off Composites at Document Level


(William Brandt) #1

Hi there

I found this:

By default ‘false’, if set to true at document level, a document will suppress composite behaviour in maps altogether.

that’s exactly what I’d like to do, but I don’t know how. Anyone able to help me with this? Many thanks.

William


(James Fallows) #2

I don’t know about the whole-document level. But as you know there is an attribute called $NeverComposite. If you set that as true for the main prototypes you use, that would do the job.


(William Brandt) #3

Thanks, that’s very helpful. That would definitely do it. Strangely enough I think I stumbled on the way to do it - involved the “get info” contextual menu option, then going to composites and setting the nevercomposite value to true… but I’ve already lost my way again and can’t find the way back to however I got there! It’s a wonderful programme but lord it’s tricky.


Map & Composites
(Mark Anderson) #4

To set a doc to suppress composite behaviour:

  • Open the Document Inspector, System tab.
  • In the search box (top box on the panel) type ‘NeverComposite’ and click Return.
  • The UI updates with $NeverComposite selected for review/edit.
  • Change the ‘default’ value from false to true and click Return to save the edit.
  • This is now the inherited value in the doc and notes will not composite in maps if dragged close to one another.

Note, when editing System or User-created attributes in the document Inspector, you are viewing/working on the attribute itself as defined in that TBX. This is true regardless of whether a note is currently selected. The other Inspectors are scoped to the current selection, e.g. as below:


(William Brandt) #5

Thanks very much - that’s what it was. Brilliant.