Tinderbox Forum

Links seem to be turned off

Hi I’ve got Tinderbox 7 installed. It was working normally but today I can’t draw links. I’ve restarted the computer and tried in different TB files but same result - I can’t drag a link between two notes in map view. If I try, nothing happens. Anyone got any ideas? Thanks!

That doesn’t give us much to go on:

  • does the link widget show on a selected map item?
  • when the cursor is over the link widget does it change from a normal pointer to a curved black arrow?
  • when you click and does a link line start drawing?
  • when you let go the cursor over another note does the link creation pop-over show?
  • when you click on the create link button does the pop-over dismiss and the link remain visible?

Also, if not doing so, I’d do basic checks with note that have a sort title and no text, subtitle or other customisation to avoid obfuscating detail.

Ok, thanks - I needed that guidance to know what questions to ask. Feel completely at sea with this. So:

Link widget shows when I select a note

Yes, changes to a curved black arrow when cursor is over it.

When I click and drag, link line does not start drawing.

When I start to drag cursor changes from curved black arrow either to hand tool or normal cursor style arrow head or insert cursor, depending, I think, on very fine distinctions in position of curved black arrow point on widget.

Link creation pop over does not show over target note.

So, can’t click on create link button.

Also, “browse links” option is greyed out in contextual menu.

With links which I created before this problem emerged, I can open link browser in contextual menu. The pop over is missing some formatting but seems functional - I can change the appearance of the link and/or delete it.

I’ve tried it with notes which have only a title and nothing else, and they show the same behaviour as links with titles and text.

Thanks for your attention to this. Appreciate it. I was wondering if I should re-download and re-install?


You’re not doing anything wrong, and the extra feedback is most helpful. So it sounds like the clicking onto the link widget isn’t initiating correctly (so of course none of the other steps follow correctly). I asked about ‘small’ notes as (elsewhere) someone had an issue with notes with lots of text at odd zoom levels - but I don’t think that’s the issue**.

I assume (but it’s still worth trying) that the link widget doesn’t work in other views, e.g. Outline, at the moment.

This isn’t an issue I’ve come across before and doesn’t appear generic. If you can, and haven’t already, I’d try first re-starting the app and re-testing. If no joy, try re-starting the Mac. The latter aren’t diagnostic, but may just get things working. either way, it’s probably worth contacting support an reporting what you’ve tried. Triaging this further likely involves a discussion less pertinent to a public forum (such as detail about your system, etc.).

Browse Links is always greyed out for any note that currently has no links defined. It is not used for creating links, but rather in reviewing/editing existing ones.

There are no bad questions. If unsure of how to frame the question (e.g. it’s unfamiliar terminology) try to give enough detail in your own words to let a fellow user here try to replicate the steps you’re going through to help find where the disconnect is occurring.

I hope you manage to get things working soon. :grinning:

** edit, seems it was! See down-thread.

One possibility: if you’re zoomed way out (that is, if you’ve used View ▸ Shrink several times) in 7.0.1, the click target for the link widget can become very small.

This will be corrected shortly, but in the meantime try linking at Normal view magnification.

You’re a genius. It was the zoom level - there seems to me to be a level of shrink where the widget actually becomes inoperative.

Without realising it I was zoomed out many times - about 10 or 11. I zoomed out to get more map in view, then adjusted the size of notes and title title text to improve visibility, which made me think I wasn’t as zoomed out as I was, so I zoomed out further… put me in a kind of death spiral of outward zoom! Now I’ve normalised zoom levels now and can get everything back to scale.

For me widget becomes tricky to use at zoom out of aroun 6 - 7 and seems to stop working at 8.

Thanks again and thanks also for being so nice!:slight_smile:

We’ve figured out why the link widget stops seeing clicks in deeply-zoomed-out maps. A test release with a bunch of fixes, including that, will be available backstage shortly, and will likely find its way into a general release in the not-too-distant future.

I seem to have an opposite problem: I can draw line between notes – but can’t see them until I zoom OUT.

Here’s a video

Can’t reproduce this. Send your sample document to info@eastgate.com

I did. Thank you very much.

Hi, Sorry if this is a basic issue. I’m very much a novice to Tinderbox, having only recently gathered the courage. from reading all your posts to delve deeper into the program beyond basic mapping and outlining.

I was wondering if there was a resolution to the problem Andreas mentioned. I have not been able to see the links I make between notes.

  1. Link widget shows when I select a note
  2. When I click and drag, cursor changes from curved black arrow to hand tool
  3. Link creation pop over appears and I select the type of link
  4. No link lines are apparent on the map, but I can see the link is present when I open the link browser
  5. Inspector shows link is there are visible checkbox is ticked.

I tried to copy the notes in part to a new file and found that the problem arose when I added more notes. No problem when I created 2 test notes, and OK when I pasted 20 or so notes, but then same problem as Andreas where the line is only visible when I cut and pasted another 20 or so notes (link lines only visible when Zoom out) and the link lines were not visible at all at any zoom level when I had added 50 or so notes.

Is there something obvious I’m missing?

Can you link to a file that shows this problem, so we’ve a common point of reference? Your checklist is useful and covers the logical things to check. For testing, I’d add #6 the assumption that these links are between items on the same map and #7 Zoom level when creating the links is normal.

You may find it quicker to send a file showing the problem to tech support (info@eastgate.com).

Anyway, on the data above you’re not making any obvious error. You do mention “pasted another 20 or so notes”. Does the error persist if you re-open the TBX and or Tinderbox itself? IOW, might the paste event possibly not be causing all links to be (re-)drawn.

FWIW, switching tabs (if only one tab, temporarily add a second) will normally force the original tab’s view to refresh.


Hi Mark,
Thanks for helping. The assumptions are as you mentioned (#6 the links are between items on the same map) and #7 Zoom level when creating the links is normal). The error has persisted with reopening the TBX and Tinderbox and as I mentioned, replicated when I cut and paste from the original file with the problem to a new file.
I’ll send a copy of both files to tech support as suggested.
Cheers, Peter

Thanks. I suspect this might need some under-the-hood inspection, so good idea to send it to support. I can say (for other readers) that this is a most unusual occurrence - I say that as a beta tester, too! Hopefully, support will find the problem.

You’ve got some notes with $Ypos values in excess of 7000 (or less than -7000), which makes the map too big a canvas for macOS to draw on.

Move those lost notes closer to the rest, or just clean up the map to a grid, and all should again be well. Or, use agents to move the originals closer to home.

Forgive the terse explanation; I’m going to miss my plane!

If new to the cleanup feature - see here for where to find it and what it does. HTH :grinning:

Thanks so much! All sorted out with the clean up (and thanks Mark for the instruction on where to find it!). Back to adventuring with the program!