Tinderbox Forum

Possible Culprits If Prototype is not working?

Symptom: When viewing notes that have the Markdown prototype assigned in the Preview pane the returned result is a zero, literally “0”.

Anyone have any suggestions as to a possible cause for this symptom?

What I’ve Tried:

  • Verified that “Markdown” prototype is attached to a test note
  • From the file menu selected the built in prototype “Markdown”
  • Closed Tinderbox. Downloaded a new version of Tinderbox and installed.
  • Create a new note at the top level in an attempt to avoid possible conflicts with other notes. This produced the same result.
  • Removed the Prototype from a note. Hence there is no prototype attached to the note. This produces the same result.

So this would appear to be not a problem of prototypes but something that I may have broken in Tinderbox.

It would seem that something I’m doing in the document is causing the problem and its document wide but I have no idea what might cause this impact.

Any thoughts would be greatly appreciated.

Thanks

MD-test.tbx (78.5 KB)

This is minimal test, created in v9.0.0. It works fine here (I’m on macOS 10.14.6, though I don’t think that is pertinent.

posting the document — or a small excerpt — might help people figure out what’s wrong

@mwra

Thanks for checking.

I believe the problem is not related to the prototype itself.

See new post below

@eastgate

Will do.

Thx

Additional Symptoms

I’ve tried opening a number of Tinderbox files with mixed results.

The most revealing might be that a couple of files display the following in their preview panes.

/bin/sh: line 1: /Applications/Tinderbox 8.app/Contents/Resources/Markdown/Markdown.pl: No such file or directory

Does this help provide an clues as to the source of the problem?

Thanks

Removing Templates Solved the Problem

In the document that originally showed the problem I had attached the “Scrivener” Template, assuming that there would no interaction between the Prototype and the Template.

However, when I removed the Scrivener Template the body text previews displayed correctly.

Is it the case that Prototypes and Templates interact, at least the built in versions?

Assuming you are using Tinderbox 9 I wonder why this is pointing to contents within the Tinderbox 8 package.

@sumnerg

I’ve installed V9 Twice and both times I selected the Replace function. Is it possible that the new version doesn’t do a clean overwrite?

Or, another idea, though a little vague, occurs to me. The file that produced this response had been created under V8 and so perhaps when the document was opened it didn’t make an orderly transition to V9.

The attribute $HTMLPreviewCommand was set to /Applications/Tinderbox 8.app/Contents/Resources/Markdown/Markdown.pl for some note or notes.

Just change this to CommonMark and you’ll be set.