Tinderbox Forum

Undo seemingly inconsistent

On a number of occasions, I have accidentally changed the color of a map element and needed to revert it. Undo seemingly does not work for this, and instead “un-does” :slight_smile: the last selection. Is this expected behavior? If so, is there a way to re-apply the prototype to revert the note to its prior state?

I just tried changing the color of a note using the Appearance inspector, and Undo behaves as expected.

If you’d like to restore any note with a color to “whatever color the note inherits”, use the Appearance Inspector to set its color to “normal”. Or, in a stamp or other action


That is odd. I just tried exactly the same thing. I selected a note, opened the inspector (cmd-1), and changed the color. The Undo command left the color intact but walked back previous actions, including adding an agent.

A second experiment may help. If I leave the inspector open and hit undo, it works. If I close the inspector, it does not revert.

Ah – this is an interesting edge case in Undo behavior; in closing the inspector, Tinderbox may be concluding that you’re drawing a line under the changes you made there.

For example, if you’re typing in a text field, UNDO undoes the typing since your last mouse action. But once you select a different field, UNDO behaves differently.

I agree that in this case it would be better if undo were not affected by closing the inspector.

New issue #1993