Tinderbox Forum

Updating not working?

Is it me or something else? I tried to update to the latest version (8.6.2) and drag it into the Applications folder as usual, but when I open TBX and go to About… I see that it is still saying I’m running 8.5.1 (b437).
Tried it twice but nothing doing. Any ideas what Im doing wrong?

Have you deleted or archived the old version?

Are you opening Tinderbox by double-clicking the Finder icon, or the dock, or a document?

No to deleting or archiving. Opening it by a) the dock and then b) the Finder icon in Application folder. In other words, what I’ve done in the past (except for opening from the Finder icon).

You must be opening the old version still installed?

I hd a similar problem both on this latest version and the one before it. I would click on the button, but there was no magic happening. Running a Macbook Air with the latest OS 10.15.3 and upgrading Tinderbox from it’s most recent prior version to the download I was attempting. After trying the main server two times unsucessfully I tried the alternate server and it worked. right away.

The main server had a hiccup for a few hours yesterday, and another hiccup for a few hours last week. If you tried to download Tinderbox from the main server at those times, you got an error message. The alternate server continued OK; that’s why we have an alternate server.

@Flailingaround Since you still have the old version installed, your operating system may be using that version. Have you copied the new version to your applications folder?

Yes, As per previous updates, dragged TBX into the Apps folder and then I go check it and it’s the old version. Normally, if I recall correctly, previous updates asked if I wanted to replace the previ0us version or keep it and have the newer one as well. This one doesn’t do that.
I suppose I could delete the existing version and try again but I rather like the way the other updates worked…

If this is correct, your Macintosh is malfunctioning. But none of this is up to Tinderbox. This is simply your macOS Finder’s normal operation.

Most likely, you have renamed the old Tinderbox, or renamed the new Tinderbox, or you’re dragging the wrong copy of Tinderbox. ⌘-I in Finder will show you information on any file, including the version of any application.

Just tried renaming the old version and opening the download of tbx862.dmg.
Dragged it to the Application folder and went hunting for it and nothing is there. Seems like a problem on my machine. But I’ve updated other software prior to this and had no issues.

Drag the file from the disk image to your desktop. Then drag from the desktop to your application folder. Verify that it’s there. Verify that it’s the version you expect it to be.

Well who’d-a-thunk? That actually worked. I’m now running 8.6.2 b452.

Thanks for that. I would not have guessed to do that.

General rule: when a computational process isn’t working, break it down into steps that cannot possibly fail. Perform each step, checking after each that it has not, in fact, failed. Eventually, sanity will prevail.

As a general rule that is true. However, if I think the first step I normally take cannot possibly fail, then I inevitably end up thinking I am insane and the world is out to get me :crazy_face:
What I need is to either a) see things differently or b) have someone else point such things out to me. I’m glad you’r my b) option. Thanks.