Watch Group in DEVONthink

I must be doing something very wrong.
In an empty TBX document I go to File->Watch->Group from DEVONthink…
I select "Choose DEVONthink Group… and “OK”
I select the group in DEVONthink from the presented popup.
In the TBX document a Container is created with the items labelled “note from DEVONthink”
These notes do not have any text or title. After a couple of seconds the “note from DEVONthink” is overwritten by a line and a new “note from DEVONthink” is created. The process repeats continuously.
Any idea what I’m doing wrong?


I also tried the DEVONThink watch group and it did the same thing, I do know the Apple notes worked like a charm.

I also get exactly this behaviour; was getting ready to make a post, but hadn’t done enough testing! It happens both with my work-day (large, complex, indexed-files) Devonthink database, and a test database with just 4 indexed pdfs.

One question is ‘Does anyone have this behaviour working as expected?’

Watching DEVONthink groups is very broken. I’ve reported this.