Tinderbox Forum

Attribute browser opens up multiple tabs

When using the attribute browser when I click on the URL icon to open a URL it opens 7 tabs. Any idea how to stop this and only have it open one?

A little more info, please. What kind of “URL” are you clicking?

If you’re in the Addtribute view and you have the URL attribute showing. If you click on the globe icon next to an icon it opens seven tabs in the browser.

Yes, sure, but what it’s the specific URL? Can you post it here?

Also, is this your web browser, and if so which one? Please don’t read that as dismissive. Sometimes these details matter. :slight_smile:

Hey there, I totally get it. :). My default browser is Chrome 84. I when I click on the URL icon in the browser it is always opening up eight tabs.

deleted - answering wrong thread

Thanks for this images. But what is the full URL you are calling in picture #2 and what are the 8 URLs opening in Chrome? By all mean sanitise any prsonal bits by inserting other characters.

Also, try setting another browser e.g. Safair temporarily as your default browser and call the same link. If it doesn’t open 8 tabs the problem is likely not in Tinderbox.

If you copy the URL field data in Tinderbox and paste it manually into Chrome’s URL bar what happens?

Look at the first image. It is https://anonaddy.com.

I set up a Tinderbox file, in AB view, with a note with that URL as the value in $URL for a note, and clicked using Safari as default, and then using Chrome as default, and I also get only one tab opening in the browser, not two, three or more tabs.

1 Like

URL is this: https://anonaddy.com/. It is the same URL in all 8 tabs. It happens with every single entry in the attribute browser.

If I paste it manually, only one tab opens. Also, if I click on it form the note’s detail view only one tab opens.

I can’t replicate this.

  • I made a new doc in v8.7.1 on my macOS 10.14.6 MBAir.
  • I added a few notes and gave each a value for $URL, one of which was https://anonaddy.com/.
  • I set up attribute browser view and set $URL as a column.
  • I then changed my default browser to Chrome (as I normally use Safari).
  • I then clicked the $URL icon for the various notes - each opened a single tab in Chrome

This would suggest that this isn’t a generic issue though that doesn’t imply your report is wrong. Other diagnostic checks:

  • Do you get extra tabs if you
  • Re-start the app. It’s a simple thing to overlook when working on a problem and sometimes this can help.
  • Make a new test doc like in my test above with nothing that you don’t need to validate the problem. Do you see the problem.
  • Does the problem occur in all your docs, just this one or only some docs?

So far, we’ve probably discounted the issue as affecting all users, but it may be the trigger is something very precise not obvious. At this point, it’s hard to tell.

Anyway, I’m sorry the cause still isn’t clear but hopefully some of the questions above will help clarify things. If still stuck it might be time to context tech support, especially if it is only happening in one TBX file.

FWIW I’ve done much as Mark A has, and created a few notes with a “URL” attribute. Clicking the link, whether in Map view or Attribute view, opens only one browser tab (I prefer opening tabs to new windows) whether in Safari or Chrome.

1 Like

@satikusala I suggest if you can create a new document that doesn’t have your private information, and reproduce the “multiple tabs” issue, then you might send that to @eastgate for diagnosis.

1 Like

Thanks, Paul. I’ve copied a number of the notes into a new file and was able to replicate the issue. I’ll send it over.

It works fine here. I think if there’s a bug, it’s a bug in your browser.

Ok, thanks. I have the latest version of Chrome. 85.0.4183.83. I just went to my MacOS setting and tested by changing my default browser. It worked on other browsers. When I changed by to Chrome as the default browser it worked as expected. So strange. I apologize for wasting people’s time; I am grateful for all your guidance.

1 Like