Tinderbox Forum

Change default line spacing?

Now that I’m writing much more in Tinderbox (rather than outlining or creating analyses) because of the great new text linking features, I’m fiddling a bit more with the text styling features.

I prefer “single spaced” text. This seems like the default in Tinderbox except there is more than a single space between paragraphs. I’d like to just have single spacing everywhere. It’s possible to set this for each note using the text ruler:

Screen Shot 2020-05-20 at 7.18.35 AM

But how can I set this “single” as the default instead of the “0.0x 6.0/6.0”?

I tried setting “single” on my note prototype, but new notes reverted back to the other setting. And I think the $LineSpacing attribute doesn’t control the “between paragraphs” line spacing setting.

Well, experimenting with all the Doc Settings for line spacing I see the following as the default spacing after using the pop-up’s offerings:

Pop-up → Ruler ‘Style’ entry → $ParagraphSpacing
none → single → 0
2pt → 0.0 1.0/1.0 → 2
4pt → 0.0 2.0/2.0 → 4
6pt → 0.0 3.0/3.0 → 6
8pt → 0.0 4.0/4.0 → 8
10pt → 0.0 5.0/5.0 → 10
12pt → 0.0 6.0/6.0 → 12
14pt → 0.0 7.0/7.0 → 14

If I manually enter a $ParagraphSpacing of 5 I get an RTF style of 0.0 2.5/2.5, i.e. (as per the ruler’s StylesOther…):

Monosnap 2020-05-20 13-02-52

So, I think you want ‘none’ as a choice so you can use plain-text double line-return as your paragraph break.

Note: because the document default from $ParagraphSpacing inherits from a Doc Setting with a pop-up (i.e. fixed list of values), only the above style values can be set as that attribute’s doc level default (@eastgate correct?).

I don’t think you can set somethying like double spacing, i.e. style 2.0 0/0, via the $ParagraphSpacing

Correct. Would anyone want to use double spacing for body text on the screen?

1 Like

mark, where are you getting this popup to appear from? I’ve not seen this one.

See here:

The pop-up is the top one next to the caption ‘Paragraph Spacing’ and as illustrated is set to ‘8pt’. Being set in Doc setting this is why the Doc default for $ParagraphSpacing can’t be set in the Inspector:

oh, I see. I thought the image you posted earlier was from the Document Settings popup, but I see now it’s from the Ruler. Thanks.

1 Like

Ah, sorry if it was unclear. :slight_smile: