Tinderbox Forum

Change default TextFont and TextFontSize via config.xml

Hi, I’m trying to change the default $TextFont and $TextFontSize via a custom config.xml (following this).

But so far without luck. After that I tried to change something in the bundled config.xml to see if this works, but this also had no effect, not after a Tinderbox restart and not after a macOS restart.

What am I missing? I’m on 8.0.3

<config version="2">
	<TextFont>Menlo</TextFont>
	<NewTextSize>14</NewTextSize>
</config>

What is your goal here? Are you changing the default font for one document? For an existing document? For future documents?

Changing config.xml would change the default setting for future documents.

For future documents

Is this config.xml thing broken?

I don’t think it’s broken; we’ll investigate. Are you modifying the config file in the application support folder, or in the document bundle?

I too have tried modifying the config.xml file (in both locations @eastgate mentioned) and can confirm that changing either config.xml file has no discernible effect. I’m running Tbx 8.1 on Mojave 10.14.6.

Slapping head

Simple explanation: the config.xml file is now overridden by the color scheme, if the color scheme specifies NameFont, TextFont, or TextFontSize.

So, don’t use the config.xml file.

  1. Instead, make a document that looks as you want.
  2. Open the Colors pane of the Document Inspector
  3. From the Action menu, select Save Color Scheme
  4. Drop this color scheme file into new documents. OR, drag it into the color schemes folder of the support folder, to make it available to all documents in the Colors tab of document preferences.

Note that you can use this to change the Modern color scheme which is initially used by all documents in light mode, and the Dark Coral scheme that is used in dark mode.

Tried step 1 to 4 but the result after dropping the exported color scheme into a new Tinderbox is not what it should be

Please send your color scheme file to bernstein@eastgate.com