Tinderbox Forum

Composite Problem


(Robert Powell) #1

I’ve got a file for taking a face to face class online that includes a goal and lots of subtasks. One of those is meetings. I created a composite for meeting notes, but it seems to be behaving oddly and I don’t know how to fix it. Here is the composite in the composite container:

Screen%20Shot%201

Notice that there is no “assignee” in the text box. I went to the outline version to check it out. Here is that result: Screen%20Shot%202

I thought I’d move “Question” to the top where it belongs and I must have assembled the composite in the wrong order somehow. Screen%20Shot%203

Notice that when I go back into the map container and select the composite, “assignee” is still not there. So I went back to the outline and “question” was at the bottom again. I once again rearrange it and then back to the map container. Here is the result:
Screen%20Shot%205

Now “question” is missing from the text box. If I go check, “question” will be at the bottom of the outline list again. Also, if I create the composite using the right-click in the main body of the map, it shows the composite correctly, but when selected one item in the composite will be missing and one of the composite components names changes when I try to enter a title, such as Question 1. I must be doing something profoundly wrong and would appreciate your help.


(Mark Anderson) #2

FWIW, when selecting manually the items are in selection order and not outline order. It may be the case that the auto-selection of all composite items follows an order that is not $OutlineOrder.

Also, doing a simple check in of a non-composite selection in Map view, when selecting 3 items is the third item has text it is shown in the text pane listing. If it has no text it is omitted. It looks like some sort of bug, the exact nature of which I’ve not had time to explore.


(Robert Powell) #3

Thanks Mark. I’ll try to make the best of it; the composite seemed like a good way to go for this particular task. I’m sure it will all get worked out. I will throw this one away again and rebuild it from scratch and make certain this time that I create them and stick them together in the sequence I want and see if that helps. I was using the outline view to organize them because I saw a post about that being the way to do it, but the post was a couple of years old and perhaps I misread it.


(Robert Powell) #4

OK, well I’ve tried everything I can think of. Clicking on one of the notes in the composite sometimes selects the one you want (e.g., Question) so the question can be entered, but then things seem to get stuck where no matter which of the notes in the composite one selects it won’t change. For example, I click on Assignee and nothing changes, it stays as When. So if I’ve got one note header correct, I can’t get it to switch to another. I think I’d best find another TB approach for this for the time being.


(Mark Anderson) #5

Although I’ve documented and tested most (all?) of Tinderbox’s features, I’ve never had a real personal need for composites so I may be missing something. I think this is the sort of issue to raise with Eastgate via tech support, if only to bottom out your assumptions vs the design intent of the features. There may be a glitch or it may simply be the feature works in a slightly different way than imagined.


(Paul Walters) #6

There’s definitely something wonky in the way this works.

I find if I add some text to the notes, then they all appear (with text) in the text panel. The order of the notes in the text panel depends on which of the composited notes I clicked when selecting the composite.

One possibility is to use the fact that prototypes can have children. So, when the prototype is assigned to a note, new child notes are created. So something like a “question & answer” prototype can have the five children listed in your post, and any note that gets that prototype will have five child notes generated.

(A bit clunky.)


(Pat Maddox) #7

I haven’t used composites really. I just did some testing and found the interaction a bit surprising.

First, the names don’t all show up on the right side, until I’ve set the text for at least one of the notes.

And to enter note text, command-click on a note to select it directly (left-clicking will select the whole composite, which is not editable).

I hope that helps some.

I love this approach.

That said, I will investigate composites some more.


(eastgate) #8

Please send a copy of the misbehaving composite example to bernstein@eastgate.com; I’d like to take a look.


(Robert Powell) #9

I’m away from my computer until tomorrow morning, but will do ASAP.


(Robert Powell) #10

Sorry about the delay Mark. I just sent it with explanation. Basically, same result in 8.02.