Tinderbox Forum

Notes sticking together?

I’m having an issue where notes are “fusing” together or a note is fusing to a container. This may be the “composite” feature—I’m still really new to using Tinderbox. How do I unstick them? It also seems like when they are fused, you can’t edit them? Like you can’t edit text in the outline for the composite form, but you also can’t select the individual notes to edit them. I must be doing something wrong here.

First, select all your notes, open the Inspector, turn to the Properties Inspector (third tab), choose the Quickstamp tab, search for the the NeverComposite attribute within the Composites group, type “true” in the box, and press “Apply”. This will make all existing notes stop compositing.

Then, in the Document Inspector, choose the System tab, search again for the NeverComposite attribute in the Composites category, type “true” in the “Default” box and press Return. Do not forget that last step. This will turn off compositing for all future notes.

Screenshot of Tinderbox (3-28-20, 1-59-50 AM)

If you want no compositing at all in any new document, set NeverComposite to “true” in all documents before adding any notes.

You can do this with Prototype settings, but I find it simpler just to turn off compositing, as described above.

Further to the last, more about Composites.

You can also go to Edit>Break Composite

Screen Shot 2020-03-28 at 8.05.32 AM

That’s better advice…

Paul, I learned a lot from your post. I didn’t realize that you could create some notes that would never composite!

There’s also an attribute $NeverComposite. Notes with that attribute on (it’s a boolean) will never composite.

Thanks very much to both of you!