Tinderbox Forum

Automatically recognizing the start and indentation of a bullet list

This is probably something obvious I’m missing:
I thought I understood from ATbRef7 that standard behavior, when typing a text in a note, was to auto-indent lists (e.g. If I type a tab, than a ‘’ followed by some text, the next line will start indented in the same way, with the same '’ so I can continue my list)
On my computer, this is not the case.

Is it a setting somewhere to recognize lists and auto-indent then automatically. It will be painful to format each line of a list when I have many, many bullet lists to type …


As far as I know, Tinderbox has the very basic Apple Text Engine behaviour for bullets: i.e. you have to invoke the first bullet / number from the Lists dropdown box (or in a slightly different form from Format > Text > List…).

NB: the Lists dropdown box is only available if you’ve got the Ruler showing (Format > Text > Show Ruler (Ctl-cmd-R)).

Once you’ve started the list off, then it will continue to indent automatically as you press Enter at the end of each list point.

BTW, you’ll probably find that the list and bullets feature is a bit clunky – that’s Apple’s fault. People have been asking them to improve it for years, but bullets (and tables) remain as irritating to use as ever.

You can avoid some of the irritation in most programs based on Apple Text (Scrivener, Devonthink, TextEdit etc) because you can press opt-tab and it will begin a bullet point (-) list.

Unfortunately it’s hardwired into the Mac so you can’t change the shortcut which means that you can’t use it in Tinderbox, as the latter has opt-tab asmove the cursor between outline and text panel’. Sadly, this command isn’t on a menu so it’s not possible to remap it.

The upshot is that the only way to get automatic bullet points in Tinderbox is to use the Lists dropdown box.

1 Like

I use bullet-lists all the time in Tinderbox. I appreciate @brookter 's back story, and would add that in practice I find this not a hassle at all.

That’s because there’s an easy key-combo to toggle the Ruler display on and off, as pointed out – Ctl-Cmd-R – and your setting for Ruler display persists between sessions. So if you turn it on, it stays on (for that file) until you turn it off. Some files I mainly leave it on, others off.

Back before v6, when Tinderbox was updated/re-written in Xcode to use current Apple frameworks, the ‘quicklist’ feature detected paragraphs starting with an asterisk and indented them (nesting inwards according the the number of asterisks) in $Text; the asterisks were also detected in HTML export and turned into bulleted lists (nested where pertinent).

Post-v6 things get more complicated with the move to a more modern RTF-based text ($text) pane in v6+. Leading asterisks are still recognised in HTML export and formatted as bulleted lists. however, in the source text the asterisks have no effect in the RTF.

If you use the RTF controls cited above to create bulleted lists you get a list in the RTF - and in exported HTML. As it doesn’t seem possible(?) to created nested lists using the RTF controls, for docs like aTbRef’s source TBX which is meant to be read primarily in HTML I eschew TRF bullets and stick with the asterisks even if I don’t get a list formatting in $Text.

I should also add that docs created pre-v6 and opened in v6+ will likely retain any quicklist-generated indenting.

I’ll think about covering this better in aTbRef but I hope that helps clarify things as the currently stand.

You still have to use the mouse to choose the list though. That’s just about ok for irregular actions such as changing the paragraph spacing, but having no shortcut for something as common as bullet points is irritating (to me at least…).

1 Like

I’m a heavy markdown user, and as such I’m hardwired to use * and 1. to start my lists, using tabs to indent as needed.

I sort of understand how the RTF-based text pane creates an issue for recognizing * as a starting asterisk, and actually, that’s probably not really an issue (e.g. typing * at each line is fine)
What really gets me every time is the lack of persistence of indentation from one line to the next, and I don’t see why it’s a problem.