Tinderbox Forum

BibDesk RIS import problem -- can others replicate this?

BibDesk, an extremely capable bibliography manager for BibTex, is one of the mainstays of my work. Since you can drag out references from BibDesk in RIS format it also integrates beautifully into Tinderbox.

However, at some point in the V7 cycle a small but very irritating problem has emerged: if you now drag out a reference in RIS format into Tinderbox a new note of Prototype Reference is correctly created; BUT an unwanted empty note titled `new’ is also created at the same time.

I’d appreciate it if others could try and replicate this problem.

(1) In BibDesk’s preferences, under ‘Citation’, ‘Copying and Dragging’, ‘Format when holding Option key’: choose ‘RIS description’ if not already selected.
(2) Option drag a reference from BibDesk into Tinderbox…

In addition to the reference do you also get an extra `new’ note?

This problem is not present in the last V6 Tinderbox I have installed – b216. Also, if you export a BibDesk reference in RIS format to a file, say ref.txt, and then drag the file into Tinderbox you don’t get a superfluous `new’ note.

I’ve just tried to replicate the process you describe and I can confirm your words.
When you set your preferences, if you indicate to BibTex that the default format of your copy and drag is RIS, you obtain this, but also with a new note. Did you notice that?

1 Like


Thank you! I was worried that the problem was unique to my setup.

I’ve been unable to replicate the problem with other RIS exporting apps; Zotero for instance doesn’t produce extraneous notes.

@dominiquerenauld – in reply to your edit – yes; it doesn’t matter if its an opt-drag or default-RIS drag you always get an extra note.

I don’t think this is a a BIbDesk RIS format problem – I’ve written minimalist custom BibDesk templates that produce the same problem and, maybe more importantly other bibliography apps accept BibDesk’s RIS output without complaint.

I’ve tried to replicate it with Endnote which I use for my references and it seems that the issue does not occur when I copy and paste to Tinderbox: there is no new note whereas it is .ris formatted.

Dd you get that from Endnote by dragging directly from Endnote to Tinderbox, or by exporting a file from Endnote and then dragging the file into Tinderbox?

As far as I know, one can’t drag directly from Endnote a RIS formatted entry into another app. So, as you say, I exported a RIS formatted file and then dragged it into Tinderbox. But if someone could replicate the process with Bookends, it would be perhaps a judicious test.

The problem doesn’t appear with file-dragging in BibDesk either, so that’s additional data too.

The problem also doesn’t appear with Bookends’ cmd-opt dragging – though there are other problems in the Bookends-Tinderbox relationship.

I’ll contact eastgate again and see if we can get this fixed.

Thank you again Dominique for your help. It is much appreciated!

1 Like

To drag from EndNode directly, cmd-option drag the reference.

… I talked about something I did not know about. Of course, it works.

Dominique, with no extra `new’ note, I’m guessing?

You guess right: no new note at all, but not without some adjustments as you can see on that picture:

Instead of Journal, which is the right $Attribute for Cahiers de psychologie clinique, I have BookTitle. But I know nothing about RIS Export.

Yes, this is a problem that occurs with a few Bibliography managers; Zotero does something similar. The problem is sometimes that RIS contains some ambiguities. What I’ve found is that through the judicious use of rules, prototypes and agents you can correct this sort of thing quite easily. If it becomes a problems for you ask and I’ll post some examples. (I unfortunately do know a bit about RIS and how to get round its `features’.)

Returning to BibDesk, this program places two items on the pasteboard when dragging references. The first item contains the RIS of all of the references in the drag; the second contains no text and its purpose is obscure to me.

If anyone can find the explanation in the BibDesk documentation, that might be useful.

For the present, the next Tinderbox release will ignore the spurious BibDesk drag item.

However, a consequence of this is that BibDesk drags will only import the first RIS item, even if the drag included multiple items. We could certainly adapt to this; it’s permitted by RIS even though it seems far more natural to provide each reference in a separate pasteboard item, and that’s what other reference managers do. As this would add a bit of complexity to the code, I’d prefer knowing that this isn’t a mistake or an archaism that will soon be corrected.

1 Like

Thanks Mark. I was preparing an email about this and you beat me to it.

That is interesting on two fronts:
First, why is this not a problem with Tinderbox 6? No spurious notes created there.

Edit 2: Doh! Obvious. V6 couldn’t do multiple imports so just ignored the second item on the pasteboard. V7 thinks the second item is a new reference, doesn’t find a TY - and gets confused.

Secondly: currently, while Tinderbox can import multiple items with cmd-opt drags from Bookends, it’s incapable of doing this from other RIS-outputting bib-managers (BibDesk and Zotero are the two I’ve tried.) You end up getting a single reference note in Tinderbox with the multiple RIS feeds all munged together in the single ReferenceRIS attribute. By comparison all multiple RIS imports between other RIS-aware apps (Zotero drag to BibDesk, BibDesk to Zotero, BibDesk drag to Bookends…) result in multiple entries being created. I.e., the only multiple-item drag into Tinderbox that works here is from Bookends.

EDIT 1: I.e., most RIS-exporting apps seem to do it by pasting a single item onto the pasteboard and then rely on the importing app to break that single item into discrete refs using TY - and ER - as delimiters. I assume Bookends is the odd man out here?

I will try and find out from the BibDesk developers if the second empty item on the pasteboard is a goof or has some deep meaning.

This problem is now fixed in the current release of Tinderbox, Version 7.2.0.

Multiple reference drags from BibDesk, Zotero and, I presume, other RIS exporting applications into Tinderbox works too. (Previously this only worked for Bookends.)

A huge thanks to Mark Bernstein for this.