Tinderbox Forum

Bookends import of multiple references in version 8.6

Is there currently a way to import multiple references at the same time from Bookends? There is a thread on this but it mostly relates to earlier versions of Tinderbox. I am using the latest version of both TBX and BE.

If I Cmd-Opt-drag from Bookends, I can do only one reference at a time. If multiple references are selected and I click then press Cmd-Opt and drag, then the first reference get created. If I Cmd-Opt and then drag , nothing happens. (Well, sometimes the result is instantly to minimize both TB and BE!)

I have read somewhere that Tinderbox can import an RIS file, but when I create an RIS file in Bookends, drag it from the filesystem, or Cmd-Opt-drag it into Tinderbox I just get a single Note, with the title of the RIS file, whereas I would like each reference in the file to be a separate Note. Same for Tab-delimited.

I am not confident with Applescript, but I have a script from the forum that I have modified and seems to work, but it also does one reference at a time. Maybe I could look at some other scripts and work out how to make it do multiple references, but I am a bit apprehensive about such non-expert DIY solutions. I am no programmer.

Alternatively I do one at a time, though that can be slow for a lot of references.

Works here. You are holding down the Cmd and Opt keys, as instructed, before clicking to start the drag. If I don’t do that I get the result you describe, thus the question.

I’ve no idea why the timing of pressing the keys should matter, but for whatever reason it does matter here.

† You’d have to ask Bookends’ dev about that.

It works for me only if a single reference is selected. If I select two references, and go either Cmd-Opt-drag or Opt-Cmd-drag, nothing happens. I tried doing it from the “All” group as well as from a Static group, and same result. I guess I can live without that for the moment.

1 Like

Doesn’t work for me either. Tinderbox version 8.6.2 (b452), Bookends 13.4

One works fine and as expected. Cannot drag > 1 out of Bookends with cmd + opt. Emailed Jon at Sonny Software to see if I’m missing something.

FWIW, I’m on 10.14.6 and v8.6.2b452 here.

Experimenting here in Map and Outline views, I’ve dragged up to as manny references in from Bookends without a problem, albeit bigger drags take a little longer to fully import and apply the prototype.

A couple of times, dragging into an Outline, the drag has bounced back, i.e. no data as imported at all. Otherwise, as long as (not sure all are necessary, but!):

  • Bookends has focus
  • Bookends has the desired selection before Cmd+Opt are invoked
  • Cmd+Opt are pressed before I start the drag
    … everything works as expected.

Possible edge cases. Pressing the modifier keys before Bookends has input focus.? Utilities such as KeyboardMaestro modifying shortcut targets. Different apps respond differently these days in whether they take window focus and focus on the click target in one click or whether two separate actions are needed: one to set app/window focus, the other to set focus within the window. App of these might be a factor.

I’m not suggesting others aren’t seeing what they do, but there has to be some cause. Given Bookends is picky about the modifier keys being active before the drag, and Tinderbox about two-click focus-setting there may be some user interactions which are read differently by the app(s) whilst ostensibly doing the same task.

For information, I discussed this with Jon at Bookends, and he advised me to try on a different machine. I did, and was able to Command-option drag multiple references with no difficulty. So it is a problem with my machine. I also stopped getting an error message relating to Bookends that Jon said was a MacOs issue. So I think the solution to my problem is to reinstall Catalina on to a clean hard drive, unless some web searching tells me an easier method to clean it up.

This is off-topic, but it makes me wonder whether I would notice any difference if I reverted to a (different) older machine that I am currently using just as a monitor for running the Bookends/Tinderbox/DevonThink/Scrivener combination. Current machine 2016 Macbook Pro 2.7GHz Core i7 with 16GB and SSD; old machine 2011 iMac 2.7GHz Core i5 with 32GB and external (T’bolt) SSD. I don’t know what hardware demands are made by Tinderbox. I am using pretty basic features at the moment, taking notes and making connections between them, though the Bookends and DevonThink databases are very large.