Tinderbox Forum

Changing font size in pane for note text

I am aware of how to change the font size within a note, and I am very happy with the display of notes in map view (it is easy to make them larger or smaller as required). But I cannot see any easy way to change the size of the text in the note view on the right hand side, which I find uncomfortably small. Ideally I would click in the pane where you add text and press Cmd-+ and the text would be bigger, but this does not happen. Am I missing something?

You can change the default font size in the note pane with Document Settings: Text.

If you select text in the note pane, ⌘-+ makes it bigger and ⌘-- makes it smaller.

Thanks. That is just what I wanted. I had been trying Cmd-+ but thought it was enough to place the cursor in the text and I had not selected any text.

Thanks again and sorry for a follow-up, but having changed the default, which is great for new notes, how can I change the font size for all the notes I created previously? What I like about the change you showed is that it does not affect the Map view display size.

I see that if I change the font size this way, it seems not to affect the font size in the Preview mode, unless I enlarge it a lot, in which case the Preview suddenly becomes Boldface. Ideally I would have the default font for displaying notes at at 18 points so I can read them eaily on screen, but with the preview at 12 points for when I want to cut and paste into a word processor. I am not clear how to do that. I guess there are two attributes I need to change in previously created notes, one for the note and one for the preview. I tried creating a stamp containing $TextFontSize=18 and applied that to a couple of notes, but nothing seemed to happen.

Select all the text in a note and choose Format ▸ Text ▸ Standard Size.

Well of course it doesn’t! It doesn’t as the Preview pane is pre-styled, at the size/style you set, for (HTML) export. If you want it bigger, alter the CSS styling the view.

Although the increase in web tech methods means the text pane’s ‘HTML’ sub-pane has been re-titled ‘Export’, the Preview and Export panes are still best thought of a HTML Export. The Export pane shows the code that will be exported for that note and the Preview pane is a lightweight internal web [sic] preview of that code such as you would see where the HTML code exported.

To see note $Text do display at 18pt. Start by opening your document(s) Document Settings/Text (via Edit menu or ⌘+8) and click the Text Font control. this allows you to set both $TextFont and $TextFontSize. On the OS Fonts palette select a font size of 18pt and close the palette. For this TBX the default $TextFontSize is now 18pt, and any new notes will use this size.

For any existing note, select the hotes, select all $Text and use Format ▸ Style ▸ Standard Size (⌘+⇧+T) and the text will re-set to 18 pt.

Preview has nothing to do with $TextFont; it shows a preview of the exported HTML. If you want to set fonts in the preview, you can add styles to your export template.

I think I am getting there. Thanks for the help. You say:

For any existing note, select the hotes, select all $Text and use Format ▸ Style ▸ Standard Size (⌘+⇧+T) and the text will re-set to 18 pt.

I have done that and it does exactly what I want, but it works only on a single note. If I select multiple notes, and then select all the text in the text pane, nothing happens. I would like to be able to select all the notes in a container, and apply the font size to all of them. But if this is not possible, it will not be a problem changing the font size on each note when I next read it.

Sorry if I caused confusion by referring to the preview pane as well. I will ignore that for the moment, not least because, in experimenting, I have accidentally applied a template that makes the Preview appear as “0”, ignoring all the text. I shall watch some more videos before trying to using it.

The text for multiple selections is not editable.

But what you see there is a ‘report’ not the editable notes. The command has to run on the actual $Text of a note. So, sadly, you have to do it note by note.

I don’t recall, but it may be the case that setting $TextFont or $TextFontSize globally or for a note automatically does the above for you. My recollection is it doesn’t. So that is why, in your case, you want to set the bigger text size when you make a new document. If that’s hard to remember to do, consider a custom config.xml file.

In Tinderbox 9.0.0, changing the default text font to a new font automatically updates occurrences of the old default font to the new default font. The font size is not changed.

In the future, changing the font size of the default text font to a new size will automatically update occurrences of the old default font of the old size to the new size.

2 Likes

Thanks both for your help. I think it is clear now