Tinderbox Forum

Color scheme is unreadable, how to change?

I just installed TB 8.0.2 and the default color scheme is unreadable. I tried to change colors in the document settings, but nothing happened. How do I fix this?

I’m attaching an image of my screen.


In Document Settings ▸ Outline, select Dark Colors or Black Titles.

Or, try the Dark Coral color scheme. (New documents created in dark mode now use Dark Coral as the default.)

From my test (whilst still in beta) the issue here is documents made in older versions and pre Mojave dar mode being opened into Tinderbox running in dark mode. Unless you’ve highly modified $Text, I found finding the view was as simple as opening the Document Settings dialog (Cmd+8), Colors tab, selecting ‘Tinderbox 7’ and clicking apply.

Dark mode doesn’t seem to have been well thought through by Apple - or at least not well documented so non-Apple devs can implement it easily.

thanks, guys. Both ideas worked.

As for Apple not thinking something through and ignoring non-apple apps…i’m shocked. shocked, I say.

I replied too soon. The above suggestions do change the colors. But the next time I open the document it reverts to the (unreadable) default color scheme. How do I make the Colors change permanent?

You might need to change the document by adding a note or editing something to convince Tinderbox that something has changed. If problems persist, email a copy of the document to support (info@eastgate.com) and we’ll get to the bottom of it,

1 Like

Same problem here - even after edits:

Every time I save, close, and reopen the document, the text has reverted to white.

(And each time, I have to reapply a color scheme (Tinderbox 7), through Edit > Document Settings)

This is a document which was first created with Tinderbox 8 - is it possible that documents which migrated into TBX 8 have some subtly distinct characteristic which protects them against this whitening out of the text ?

PS This was not the case with 8.01

8.02 bleached out the text for the first time, and is continuing to do that …

It’s a logic error in dark mode support. 8.0.3 should fix it, and should be available by the time you read this.


That was quick !

Many thanks