Tinderbox Forum

Composite and outline oview

In outline view, how do you decouple one or more notes from a composite?

In Map view it is simple, you just hold the command and drag.

In outline view this same action just appears to move the note, it does not decouple the note from the composite.



I make a habit in a new document to turn off compositing like this:

Screenshot of Tinderbox (12-28-20, 9-15-20 AM)

1 Like

At a per-note level, in a non-map view select any note in the composite, thus the whole composite and Edit menuBreak Composite. This ‘de-composites’ the entire composite, which in a non-map context makes sense as the feature is a map view affordance.

. There is no shortcut, lest you wonder.

In map view the same option is available, i.e. breaking the entire composite, in addition to Cmd+click-selecting a single composite item and dragging it out of the composite.

Further to @PaulWalters’ note about the $NeverCompostite system attribute, there is sadly no Document Settings option for this, so using the Document Inspector’s ‘System’ tab is the only practical method to disable the composite feature at document level.

Perfect, thanks! All makes sense.

I think this is one of those rare cases where the default for an attribute for new files is wrongly set.

Of course, whichever way any default is set, there’ll always be occasions when you wish it was the other way round, but I would have thought that the proportion of ‘normal’ notes is so much greater than ‘composed notes’ that it would be better to have the combining feature turned off, rather than on. It’s irritating (and confusing the first few times it happens) to have notes glue to each other in Map view when you don’t want them to.

Of course once you know what’s happening, there are workarounds, but shouldn’t defaults be set to the most common option? How many people always start off files with composite notes as the main feature? (That’s a genuine question, by the way…) Shouldn’t setting a composite be a deliberate decision, not the accidental result of clumsy mousing?

Yes, I know this is a minor point…

1 Like

Oh, I know there are workarounds, thanks!

The point still stands, you’re having to make special arrangements to cater for the most common situation (notes shouldn’t combine accidentally), rather than explicitly choose to configure for the rarer one (in this file, I want these notes only to combine).