Tinderbox Forum

Dragging references from Bookends causing unexpected behavior

Hi, I’m a newbie and having a problem. I’m dragging over (command+option; RIF format) references from Bookends and having some issues.

First, I can’t understand why, but after the Reference prototype and new note is created with the same prototype applied, that newly created note wants to stay selected no matter where I click within the program. I could have another note selected or in the inspector somewhere and within 10 seconds (always different), that reference note will become selected all on it’s own. Is this meant to happen for some sort of reason such as it’s waiting for some kind of input? This doesn’t happen with other kinds of notes.


Second, none of the key attributes are being filled.

Any help would be appreciated.

What version of Bookends are you using? Bookends 13 introduced quite a few changes that might affect the export data.

Newest version as of today. Version 13. :frowning: Surely if using unformatted text it shouldn’t make much of a difference?

I reinstalled 12.8.4 with a new db and preferences file to test it and it’s acting the same way.

I tried v11 as well. Then I used AppCleaner to catch all the files I might have missed and made a fresh install of 13 once again with a new library. It seems to be working fine now. I wish I could say what it was but I can’t. Anyway, v13 seems to be working fine after a very fresh install. Actually, the old library is working fine as well. :slight_smile: There’s about 4 hours and one evening of study down the drain.

This sounds like, for some reason, Bookends was not receiving, or was unwilling to handle, AppleScript events. The restart resolved the problem.

1 Like

I have had similar issues with AppleScript events not working between MailMate and OmniFocus. In all cases so far, a restart has solved the problem. Not sure what’s causing it, but seems related.