File won't open

I was working with a Tinderbox file this morning when I got the swirling beach ball. I closed the file, relaunched the app, and tried to open it. But no. After ten seconds or so what opens is the default untitled file. I’ve tried this repeatedly, rebooted computer repeatedly, same thing.

Then I noticed the file size: 3.6 gigabytes! How it got that way I have no idea. I made a copy of the file just last week, which is all of 48 megabytes. I added a bit over the last week, but not much.

If anyone has any idea what happened, or how I can fix it, please let me know.

This is my key working file. Because I have the backup, a loss won’t be a major tragedy, although I’ll have a couple hours worth of work to re-enter the latest material.

  1. Find a way to share the file with support: Dropbox, perhaps. We may be able to fix it, or at least figure out what’s so big.

  2. When a file opens empty and untitled, that usually means that the XML has been damaged.

  3. Don’t forget Time Machine, assuming you use it; you can pinpoint precisely when the file size changed. That might save you re-entering some material.

  4. Common culprits causing big files are (a) pasting huge images (which might not be obviously big) such as pdfs, and (b) having a process that creates notes run amok.