Tinderbox Forum

Hyperlink in Notes


When I am writing in the notes text section. I was wondering if I can hyperlink a word instead of copy pasting the URL

Click here instead of go here https://…


This has always been possible and is explained here. :grinning:

1 Like

@mwra: In the aTbRef link you mentioned it says: to make a Web Link “use the [Cmd]+[Opt]+[Ctrl]+L” where it actually should read " [Cmd]+[Shift]+[Ctrl]+L"

Maybe you could kindly adjust this.

Thanks you!

What makes you say this. The menu clearly marks the shortcut as “[Cmd]+[Opt]+[Ctrl]+L”. On my system “[Cmd]+[Shift]+[Ctrl]+L” does nothing.

Actually, neither of the above works for me in v7.3.1. So, I think the aTbRef note is correct in terms of how the app lists the shortcut, even if it doesn’t work

You’re right, @mwra. I was mistaken. Sorry.

What do you suggest: To either delete my entry in order not to confuse other readers or to keep it as my mistake provoked your clarification that the actual menu shortcut does not work (at least not in v 7.3.1).

Either way, I let the @eastgate support know.

Just leave the earlier post as it is - reading the thread will explain.

This is useful anyway as testing resulted in me finding 2 other typos in shortcut notes and we’ve found a shortcut that’s not working and which will now get reported. :grinning:

Alright, great! Thanks!

⌘⌥^L works as expected here, provided (naturally) there’s a span of selected text in the text pane and that the text pane has the focus.

Odd, it fails here on both my Macs, even after re-starting the app (both for v292 and most recent built). I’ve tried closing all other apps, except my web browser (as I’m typing this) in case another app has grabbed the shortcut but still no joy. Odd, I definitely recall it working not long ago.

Fails here for me as well. Another oddity as well: it works fine if I use the menu item command. But if I just put “www.google.com” it won’t open it, saying there’s no application to open the file. I have to put http:// or https:// in there. Seems…bugged?

The ‘URL’ has always been the full URL. The fact one can type an incomplete URL like ‘google.com’ or ‘www.google.com’ into a web browser and it be interpreted as ‘http://www.google.com’ is, I understand, something built into the web browser. (Indeed, I see the forum software is automatically doing similar with the first two even though I added no mark-up and don’t want [sic] a web link there and can’t remove it!).

So, is the Create Web Link dialog faulty no. Could it be easier for those unfamiliar with URLs? Tinderbox by habit doesn’t throw lots of effort so a partial URL placed in the $URL field will give a silent fail. I don’t know if the newer macOS frameworks used since v6 allow the same sort of fixing of user input as done by web browsers, but I guess that would be a feature request at this point if you want to make it. As users, we can’t modify the current behaviour.

A post was split to a new topic: Additional $text area context menu options