Tinderbox Forum

Import of multiple references from Bookends

I am using Sonny Software Bookends v13.2 and Tinderbox 7.5.6

Command-option-dragging a single reference from my Bookends library into an empty TBX words as advertised. It is imported, a Reference prototype is created and assigned to the article. However I have 90 refs I want to import (and then organise using Map View) and command-option-dragging of multiple items from Bookends doesn’t seem to work? (You don’t see the little up-and-to-the-right curved “alias” arrow next to the mouse cursor and nothing is dropped into TBX).

Any advice or help please?


This seems to be a limitation at the Bookends end. Notes on formatted drag-drop from BE state:

N.B. Bookends requires the Cmd+Opt keys to be depressed before clicking on the item to drag; otherwise, the import to Tinderbox does not occur correctly.

If I do this with more than one note selected, BE doesn’t generate a drag object.

You can also select an item in BE and use edit -> copy hypertext link -> coy as link link (Cmd+Shift+L) then paste. If I try this approach with a multiple BE selection, then only the first item in the selection is pasted in.

On the basis of this evidence I’d check with the BE forums first and confirm a multiple selection can be dragged as formatted into.

1 Like

Suggestion: select your 90 references and export them as RIS. Then, drag the exported RIS file into Tinderbox.

Thanks - here, for reference, is Jon’s reply


Bookends places each selection in a drag item, it’s up to the receiving application to unpack them. Here’s an example of what the drag for 4 references might contain


I suspect Tinderbox isn’t looking for any except the first. You can let Mark know this, and include this email if you like, so that if he has any questions we can discuss it.


Sonny Software

Hmmmm. I just ⌘⌥-dragged 3 references from Bookends to Tinderbox, and all three were imported appropriately. I repeated with 25, and that worked as well — though it took about 15 seconds.

Thanks Mark - definitely not working for me I’m afraid. My sense is (despite Jon’s email) that the problem is at the BE end. In BE, if I select multiple rows and option-drag I immediately get “ghost” copies of each row with the adjacent green-circle “+” sign indicating that I’m going to be copy-dragging items. But command-option-dragging results in nothing: no ghosted items, no (in this case) “alias-curly arrow” alongside indicating this is a special kind of drag, and moving the cursor over onto TBX does nothing in that TBX doesn’t get focus. Happy to go back to Jon if that seems relevant

By command I meant ⌘ so I’m confirming nothing happens with ⌘⌥-drag for me (no “drag object” is created)

This is a head-scratcher.

  1. Select several things in Bookends
  2. Press and hold ⌘ and ⌥
  3. Click on one of the selected things, and drag them into Tinderbox

This works for me in 7.5.6 and in the current backstage version

Testing using Tinderbox b353 + Bookends v13.2 on OS 10.14.3

I suspect it depends on whether you press the modifier keys before mouse-down - as per the original instructions.

If I Cmd+Opt click before starting the drag:

  • With 1 BE item selected, the drop creates a note that Tinderbox makes into a reference.
  • With multiple BE items selected, no drag occurs.

If I Cmd+Opt click after starting the drag:

  • With 1 BE item selected, the drop creates a note who’s title is the BE item in it’s default export formatted form.
  • With multiple BE items selected, the same occurs as above as only the first item of the selection creates a note, and not of the desired. trype (i.e. a reference note).

This used to work for me, but doesn’t any longer. Works fine and as expected for 1 reference. On multiple, I get the content expected for a copy paste (in my case, the BibTeX citekey).
Tinderbox 7.5.7 b350, Bookends 13.2, Mojave 10.14.3

That is to say – I get similar behavior to what Mark describes.

OK: let’s see if we can pin this down together. Try this:

  1. Open Bookends, and also open BBEdit or another text editor
  2. Select several references in Bookends
  3. Press and hold ⌘ and ⌥ keys
  4. Drag the select items, and drop them into the text editor window

What I see is a series of URLs:


What do you see?

For me, no drag at all results if more than one BE item is selected. If only one item is selected the above process (using BBEdit 12.6.1) works and results in (one) BE reference URL.


I’m doing the drag using the trackpad on my 2013 MBAir (10.14.3) and I’ve no funky utilities that hook into my trackpad/cursor (or of which I’m aware).

I can’t figure how some can Cmd+Opt+drag multiple items, but I can’t. For me, in BE a multiple selection can’t be moved at all.

I get the same result as Mark A - I can’t cmd+opt+drag multiple objects out of BE. No “drag object” image of the multiple references is formed (in contrast to opt+dragging as I mentioned above), and the focus doesn’t move away from BE when I move the cursor out of the frontmost BE window. FWIW I’m using a wireless Logitech mouse (MacOS 10.14.3)

I’ve written to Sonny Software; this is a head scratcher

Just to be sure we’re all on the same page:

  • We’re all dragging from the main Bookends table?
  • We’re all dragging into the Tinderbox map pane?

If you don’t see a drag from Bookends, are you using Dark Mode ?

I’m dragging from the main BE table to the TB Outline view and am using dark mode.

Ok, switched to light mode, tried to Cmd+opt+drag a 3 item selection from BE. No UI feedback from BE of a drag and nothing arrives in TB. I can drag 3 items from BE, albeit with a different outcome.

I can confirm I’ve been using Mojave in Dark Mode though it’s going to be a couple of days before I can get to test anything systematically I’m afraid

A very quick play suggests that switching out of dark mode makes no difference for me - still no drag object with cmd+opt+drag…

I’ve used Mark’s export to RIS workaround for now but it would be good to get to the bottom of this!

An update for me with TBX 8.0.0 b362, Bookends 13.2.1, Mojave 10.14.4 (not dark mode) on MacBook Pro (Retina, 15-inch, Late 2013):

cmd-option-drag works to bring in multiple objects to Tinderbox from Bookends, and the prototype is created properly and assigned to the references. However, none of the attributes are populated.

cmd-option-dragging to BBEdit results in a newline-separated set of bookends:// URLs.

Does Tinderbox have to call back to Bookends to get the information for/from each of the references?

Prompted by Naupaka’s post I’ve just gone back and checked this, now using TBX Version 8.0.0 (b361) (I was previously using TBX7). It is now working as intended (i.e. can cmd-opt-drag and drop multiple refs into Map view and have multiple prototyped articles created. For me (unlike Naupaka) the attributes do populate correctly.

The only clue I have to offer is that on this occasion (presumably because this was the first occasion for me of an interaction between TBX 8 and Bookends), I had a “TBX would like to control Bookends” permissions pop up which obviously I granted. This never occurred with my TBX 7 attempts. No idea if that’s relevant?

Anyway, thanks again Mark B for all your ongoing efforts. Really enjoying TBX 8