Tinderbox Forum

Interface glitchy with window hacks (renamed)


I’m a new lover of TBX and have a question that I wonder if anyone can help me with. I’m having issues with the display associated with how the trackpad acts in the map view. Some issues include:

  • Clicking or double clicking to make a new note but the map repositions itself.

  • Resizing a note is difficult as when I let go of the click, the note resizes itself to some random size and/or position.

  • When repositioning a note, a composite is created (this one is really annoying)

These things are difficult to reproduce on demand, but are happening nearly constantly. I have witnessed this same behavior in PDFpenPro, but not in any other application–ever. The only thing that helps is to use a mouse–even a magic mouse. (I can’t stand using mice)

So I’m wondering if anyone has ever encountered anything like this or has any suggestions about what it could be. I don’t think it’s TBX itself but is likely something about how it (and PDFpen) uses a magic trackpad.

Thanks in advance!

Me too.

I’m experiencing #1 and #2, and some other trackpad oddities. I have not done any trouble-shooting. All other programs run without issue. I do use BTT (Better Touch Tool). Tinderbox 7.3.0 on OS 10.11.6; MBP 10,1.

I’m using an iMac running High Sierra without any pointing device altering tools. I am using FinderMinder and SizeUp. The former keeps the Finder where I want it and at the size I want it while the latter resizes and repositions windows with keyboard shortcuts. I’ll make a video. Thanks!

Here’s the most boring video ever. You can see at times the map reposition itself at unexpected times and at least two different times a note changes shape/size as I’m releasing the drag on the trackpad


Right, so I’ve done that numerous times for other reasons but for some reason never thought to do it for this situation. Under a new user account, it worked fine. The very first program I thought to bring up (which I didn’t mention earlier) was Contexts (better window switching with keyboard). As soon as I opened Contexts, the same glitch behavior started. So I logged in to my normal user account, opened TBX, and saw the glitchy behavior. I quit out of Contexts and like magic, all is well. I should have done that. Thank you PaulWalters for helping me remember to try that. Of course, that’s a bummer for me about Contexts as I use it constantly.


You might give Many Tricks’ Witch a try. (Does what Contexts does; I don’t know if it will have the same effect on Tinderbox.)

1 Like

Thanks Kirby. It seems that it certainly does and plays fine with TBX. Contexts developer is super nice and helpful and the app has always worked great otherwise. I thought he deserved at least that mention.

Thanks again!

1 Like

Glad it’s working for you :blush: . I think Many Tricks does elegant work. I use and recommend Witch, Name Mangler, and Moom.

1 Like

Just to report back – I’ve been running Contexts side by side with Tinderbox 7 for over 80 hours of usage this past week and have experienced no visual glitch such as what @TheOwl described. I’m pretty confident of two things: the culprit isn’t Contexts – at least not by itself – and Contexts is very good at what it does.

So I’ve ditched Witch (no loss, IMO) and licensed Contexts (significantly better feature set).

Well, Tbx is still working fine for me with Contexts not running. Maybe it was a combination of Contexts with some other program that I use with similar GUI capabilities. I do like Contexts much better than Witch, but only cause I can’t figure out how to get it to do the same thing. I haven’t had much time other than an initial set up of the trial. For example, command+tab isn’t working at all for some reason, so I need to use option+tab. Then what I would like is to have the program window that I had used just before to be the first option selected when I shortcut to the switcher. Witch isn’t doing that. I’ll play around with Contexts in juncunction with some of the other apps and see if it changes anything and will report back.

I gotta say, BBT, which I had also not heard of, seems to be a decent replacement for an application switcher, window repositioning tool, and obviously all the touch enhancements. It doesn’t do what Contexts does in terms of being able to switch between all open Windows instead of just all open apps (say for example you are looking at multiple PDFs at the same time), but it’s still pretty damn good. It would be nice to consolidate all the little apps taking up memory and meddling at system level with a single, well designed and supported app. Nothing could replace LaunchBar though!

Opening up Contexts again today gave me the erratic behavior I have been describing, but an update seems to have fixed it. That’s interesting as this behavior has been going on for over a year (with PDFPen) but suddenly it’s fixed when I mentioned it here. I wonder if they saw this thread or if it’s just a coincidence. Anyway, it’s appreciated that it’s up and running again.

Hi all, first post, sorry it’s about a glitch!

I’m experiencing the same issue. If I click on the background and drag around to move the canvas it works fine, but if I click on an adornment and drag around I get the same behaviour as in the video above; the canvas makes an abrupt jump to some random place before I start dragging. Sometimes the jump is so abrupt that the item I clicked on to drag is positioned off-screen somewhere and I have to drag around randomly to try and find it again.

I’ve never used Contexts (never even heard of it, actually) but I do use BTT and BetterSnapTool. However, I’ve turned off automatic start and rebooted to make sure they’re both cleared out and the problem still happens.

My machine is a MBP 2017 15" with highest spec (except a 1TB drive instead of 2TB).

To finish on a more positive note, I’ve spent all weekend reading about Tinderbox and going through Mark’s aTbRef website and I’m pretty sure I’m going to love this product! Even though I’ve only been using Tinderbox for literally a minute before running into this issue I already know I’m going to purchase the software and love using it. :slight_smile: (aTbRef has made the sale!)

/edit - here’s an example:

If I click on the background or on one of the notes and drag it’s ok, but if I click on the adornment and drag it goes wrong.

1 Like

Please fix this soon. I’m loving my time working with Tinderbox except for this one thing which is really annoying. It’s not just randomly moving the grid around, it’s also randomly moving objects around in the grid. And what makes it worse is that the move isn’t added to the undo/redo list so the move can’t be undone. Thanks in advance!

1 Like

Are you using any other programs that might interfere in one way or another? Not using Contexts helped fix my problem, but it could be something else for you that interacts in a similar way with the system as Contexts does. I’ve got all kinds of little apps that I enjoy. Recently Better Touch Tool since learning of it here. But here’s some others I use: Contexts, Text Expander, SizeUp, FinderMinder, Unclutter, Flux, Duet, Parallels, LaunchBar and Webcam Settings.

Basically, anything that didn’t come with your Mac that changes system preferences in some way. I’d consider quitting out of them one at a time to see when Tbx starts working better. You can quit out of programs like that by using Activity Monitor in your Utilities Folder in Applications. It’s just a thought. I don’t think it was necessarily Contexts for me. I think it was Contexts in conjunction with another one of those apps, since I use so many.

Since the last Contexts update, not only does Tbx work correctly but so does PDFpen. I’ve had a problem with PDFpen for over a year to the point that I had stopped using it.

I’ve tried removing the utilities I have installed but with no luck. Also, Paul (above) replicated the problem on a fresh user account (presumably with none installed).

I suspect something is amiss with the logic that translates the raw cursor position on-screen to the map coordinates. Just a feeling.

I don’t need anything to be locked for strange things to happen. For example:

  1. Start a new document
  2. Go full-screen
  3. Double-click to create a note a couple of inches from the left side of the screen
  4. The note is created, but the splitter between the map and the text also moves to edge of the note. I was nowhere near the splitter.

This happens reproducibly.

I can make this happen too! Hadn’t encountered it in 10 years of using the program, which makes me think it’s an edge-case combo of (a) brand new empty file receiving its first note, (b) starting out in Full Screen view, and © map view with splitter enabled.

As a practical work-around, these seem to avoid the issue for me:

  1. Create that very first note before you go into Full Screen view, and then go into full screen. (At least for me, the problem doesn’t come up that way.)
  2. Whether in Full Screen or normal-window view, hit Cmd-6, so the splitter goes away and you’re seeing the map pane only; enter your item in a new file; then hit Cmd-5 to bring the splitter back (and seeing the note pane on the right). For me, that avoids the problem.

Ie, I think you’ve found an anomaly, which Eastgate can add to the list, but it’s one easy to avoid by either entering the very first note before going into Full Screen view, or by hitting Cmd-6 before entering that very first note. Or by panning the map placement back where you’d like it.

I just used that to illustrate that there’s something amiss because it was the easiest and quickest way to reproduce the issue - like you say, it’s not hard to work around and it’s not even that big a problem in the first place, but it makes using maps pretty painful (thanks for taking the time to help, though!)

We’re confounding several things here.

  1. An issue that arises in full-screen mode with empty maps, not reported before today, but now well described;

  2. Apparent issues with some esoteric third-party programs that hack macOS in unsupported and undocumented ways;

  3. Other issues which are not sufficiently well described or reproduced to allow anyone to approach them.

This isn’t helping. I’ve logged the problem that tech support can address, and will shortly delete this thread.