Tinderbox Forum

Issues with Document Settings - ⌘8

Starting a new TBX file, saving it with a name and ⌘-8 to Document Settings. In the Maps Tab set “Adjacent Notes Form Composites” then move to tab Text and back to Maps and the setting for “Adjacent…” has been cleared.
My view of the logic is that the Document Settings is used for user “Global” settings vs the case where $NeverComposite can be used more selectively ie on a per container basis.

@eastgate, I can replicate this. The Document Settings control doesn’t ‘take’ when set. Also in the Document system Inspector for $NeverComposites the pane should shown the default value as being set via preferences (i.e. doc settings). At present, Doc Settings is inheriting the Inspector value rather than vice versa with is the current norm for Pref/Settings controls that alter a system attribute.

@gul-iMac For this setting, as at v9.0.0, is this workaround:

  • close Document Settings.
  • open the Document Inspector
  • select the system tab, if not already selected.
  • in the search box, type NeverComposite (or select an autocomplete for that as you type. Press the Return key (:leftwards_arrow_with_hook:).
  • the data for the NeverComposite loads.
  • in the Default box set false if you want composites to occur, or true if you don’t want that. To occur. The v9.0.0 doc setting/Map will then reflect that setting.

Note that the label of the tick-box is the reverse of the underlying attribute’s true/false . Thus

If $NeverComposite is true, the Doc settings 'Adjacent Notes Form composites; is un-ticked (i.e. they never composite).

If $NeverComposite is false, the Doc settings 'Adjacent Notes Form composites; is ticked (i.e. they do composite).

1 Like

OK, nice example of using the Document Inspector.
Thank you.

1 Like

We’ll get to the bottom of this!