Tinderbox Forum

Linking with text parking space and autocomplete deletes target note, trying to figure out what is wrong

This is a problem with something in my system interacting with Tinderbox 8.2.2, I suspect. Trying to get to the bottom of it, I am posting here in the hopes that this knowledgeable and wise community might have some suggestions.

The problem: In Map view, when I try to link Note A to Note B via the Text Link parking place, Note B is destroyed. See video clip. The note vanishes, and only its name remains on the map, with no body. It does not turn up in a Search any more. It’s gone. The same thing happens in Outline view.

I sent this to Eastgate, confident I had found a bug, but Mark B cannot reproduce it. Therefore it is something about my System, I guess. But what could it be?

The problem has persisted after (a) restarting Tinderbox, (b) restarting the computer, © trying on a different, older computer (which has much the same configuration to the one I use daily) (d) upgrading from Mojave to Catalina on one of the computers and (e) restarting that computer in Safe Mode. Thinking that it might have to do with Dropbox (where I save most Tbox documents), I tried the same maneuver with a doc saved locally to my hard drive. Same result.

Is this associated with the update to 8.2.2? I don’t know. I haven’t had a problem before, but I was hardly using links (I usually use attributes and note locations to organize). So I can’t say for sure.

I’d really like to figure out what it is about my OS that is causing this. All thoughts and suggestions welcome!

Details: 2018 Macbook Air running OS 10.14.6 and then running 10.15.2; 2012 Macbook Pro running 10.14.6. Both machines running Tinderbox 8.2.2 build 241



I cannot reproduce this with the current public release of Tinderbox on 10.15.2, on a new user on a new-out-of-the-box MBP.

I didn’t see “tested on a new user account” on your list of trials. If it works on a new user account on your normal machine, then that’s pretty good confirmation that something is interfering with Tinderbox in your regular account.

Aside from the difficulty we’re having reproducing this, there are many other ways to accomplish the same task in Tinderbox. I’ve renamed the thread for clarity.

Thanks for the suggestion, Paul. I created a new user on the older machine, and did the same test.

Same result: Linking from note “Test 1” to “Test 2” via the text-window parking space wipes out “Test 2”. So it is not specific to my user settings, whatever it is.

Fair point, Mark, and thanks.

Here’s my workaround: I take the link from Note A and park it in the Map’s Link parking space at top left. Then I switch tabs to the Outline view, find target Note B, and take the link from the parking space to it. It’s relatively easy to find a target note in Outline. Thus I avoid the (for me) nonfunctional autocomplete route.

This doesn’t work for linking text to a note but that’s not what I am using the links for anyway, so it’s livable.


How about dragging the link to the main parking space?

FWIW, I do see the reported issue using v8.2.2b421 on 10.14.6. Interestingly, the missing note seems to persist for the current session though it isn’t drawn in any view. Here, ‘Test 1’ has been linked to a now-invisible ‘Test 9’:

But if I select ‘Note 1’ and follow its text link, ‘Note 9’ is selected in the text view and re-drawn in the view pane:

If I mouse over the ‘Test 9’ label in the text pane, unlike with correctly generated notes, the there is no tool tip showing the note’s path ($Path). Tab-switch doesn’t ‘fix’ the bad notes. A click on the current tab (to force a refresh) keeps the ‘bad’ note selected but it disappears from the view pane:

Saving/closing/re-opening the document results in the missing notes being lost. Functional text links to them (as above) are also lost. Perhaps this may give @eastgate some more clues as I understand the difficulty of diagnosing something that can’t be replicated locally.

This works for me when drawing the link with the cursor. If I use the drop-down autocomplete menu, the link from the main parking space destroys its target, just as it does when using autocomplete from the text-box parking space. So for me at least the problem with the autocomplete menu is not confined to one parking place.

Thanks, Mark A. This bears a strong family resemblance to the problem I’ve had – though in my case, when I select ‘Note 1’ it reports that it has no links. This means that Note 9 in my case doesn’t persist at all. The only trace of it is its name, lingering without a box in the map view.


Look my screencast about this bug.


This has been addressed and is currently being tested backstage.