Tinderbox Forum

Note's selected Title replaced by capital "i" when switching back to "Text" tab

I keep running into small glitches that keep me from even asking about other issues. This is the latest. Could someone confirm if that happens for them, and/or suggest why it is happening for me? Persists after re-boot. Tinderbox 7.30 on OS 10.11.6.

With the Title field of the Text pane active, if I select either of the other Text pane tabs, viz.: Preview or HTML, and the click on the Text tab button to return to the Text tab, that button turns light gray and nothing else happens (the current Text pane tab remains displayed). If I click it a second time, the Text tab is displayed in the Text pane, and the text in the Title field is replaced with the capital “i” character.

I have tried this with several Notes and two documents. The behavior is the same.

I do have running all of: Keyboard Maestro engine, Better Touch Tool, LaunchBar, Witch, and other utilities.

I’m on 10.12.6 with v7.3.0 and can’t replicate this. If the title in the text pane is in edit mode, i.e. selected, I can still switch to other text sub-panes and back without issue. On return to the Text pane the title resumes edit mode.

1 Like

Thanks Mark. I will look into local causes.

I can replicate the behavior with each of Keyboard Maestro Engine, Better Touch Tool, Witch, and LaunchBar closed. In fact, the behavior persists even after booting into Safe Mode and running only Tinderbox. (This last is definitive afaik — I don’t know what else to check.)

Tinderbox 7.3.0
OS 10.11.6
MBP 10,1

I’d suggest taking this to tech support for more effective triage.

Just tried this with several files. Not able to recreate the behavior you describe. Tabs and click-buttons all work fine.

Am using OSX 10.13.1 / TB 7.3.0 / Keyboard Maestro but not any of the other utilities you mention.

1 Like

Thank you for checking. Could be a 10.11.x wrinkle. Until I have ported all my data from Circus Ponies Notebook (possibly into Tinderbox) and Aperture (into Lightroom Classic) I’m freezing the OS on this machine at 10.11.6. (Once I have successfully ported everything I will replace this “early 2013” Mac with a new one.)

Can’t replicate here, either. Not very likely to be a macOS issue, either.

Safe Mode is probably irrelevant, too; setting up a clean user account is probably better.

1 Like

Does the problem occur on notes with an empty $Text attribute? If it doesn’t, does it occur on notes with a single character in the $Text attribute? If it’s still ok, what is it about the other notes that causes the problem?

My understanding was that Safe Mode was even “cleaner” than a clean user account.

Regardless, the mis-behavior happens exactly the same with a newly created user account with only Tinderbox running and only one Note.

I realize this is probably local to my machine, but it’s vexing. Are there other trouble-shooting steps you recommend?

The misbehavior occurs regardless of whether the Note contains text or is empty (or has a single-character as its content). Interestingly, perhaps, the misbehavior does not occur when $Name is empty. In that case, not only does the Title remain empty, but the first click on the Text Pane Selector Tab “Text” returns the Text Pane to Text view (when the misbehavior occurs, the first click only causes the “Text” button to change shading; the second click on the button changes the view back to Text view and replaces the Title with a capital “i” character). When $Name is a single character, the misbehavior is the same as it is in all other cases.

The misbehavior happens on every Note I’ve tried, in new and not-new documents, in new and not-new User Accounts, and even after booting into Safe Mode. It only happens when the Title is open for editing when the view is changed.

NB: I am new to Tinderbox. I have tried to name the parts accurately and use the names correctly. I am using “$Text” to mean the content of the Note, and $Name to mean the Title of the Note, known in Tinderbox as the Title.

Could you post a screen capture or video showing the glitch in action?

I know when the cursor is in the $Name field, and I switch from the Text selector to the Preview selector and then back, that the whole contents of $Name is always selected – so I assume it is at exactly that point that the content of the name display is suddenly replaced by capital “I”. Might be helpful to examine that instant on video.

Yes. I’m not sure how best to post it, though. Here is a link to the 5MB MOV file in my Dropbox.

Note that I issue no commands from the keyboard. The only typing appears on screen, except for when I type {return} after typing the Note Title.

Let me mention that I am completely prepared for this to be user error (I just don’t see it). And it still is likely local to my machine. Thanks everyone for your continued help.

Thanks for the video link.

I have seen this sort of behavior on a MacBook when the battery was overheated and causing problems with the keyboard. (Not with Tinderbox.) But not in a repeatable way.


Wow. I think we are close. My MBP has a very bad battery (I’ve needed to replace it for months {“Battery condition” = “Service Battery”}, but it means being without the computer for 7 days). I run it on AC power only, but the system still is affected by the in-need-of-replacement battery.

Coincident with the battery going from “bad” to “near death”, I ramped up my use of Tinderbox. In my use of Tinderbox — and, so far, only in Tinderbox — I experience multiple unexpected behaviors, which I attributed to Tinderbox. I will suspend all judgement until I either move to a new machine or replace the battery in this one.

I will see if the misbehavior persists on a machine that does not have a battery in need of service.

Have a good Thanksgiving (if you are a US citizen). I will raise a glass in thanks to you :blush: .


1 Like