Tinderbox Forum

Sculptural Hypertext - how to begin?

After a year of distractions I finally plunged myself into Storyspace 3 and accompanying texts (Storyspace 3 and Storyspace and Hypertext Narrative) and I’m loving it: congratulations, Mark!

Nevertheless a frustration glooms. Storyspace help chapter (longer paragraph) on sculptural hypertext and even long passages in Hypertext Narrative about the techniques of sculptural linking (unlinking), neither Howard Oakley’s friendly and useful blog entries do not help me in getting the idea of Deck working. I was following this introduction:

"$Deck is a set-type attribute but is typically simply the name shared by a deck. We might have a deck named “shipboard” that describes a transatlantic voyage in 1932. To “pick up” the deck at the beginning of the episode, the initial note named Bon Voyage sets $Deck(/me)=“shipboard”. Bon Voyage has no outbound links, but because $Deck(/me) is “shipboard”, trying to follow the default link from Bon Voyage will cause Storyspace to randomly select one unread note which is marked as having a $Deck that contains “shipboard”. This will continue until we reach a note that has conventional calligraphic links, or until some note changes $Deck(/me). "

In my Storyspace file there is a starting page, a "me’ page, a “Bon Voyage” node and 4 test nodes, each of them attributed to the “shipboard” deck. Start page links to “Bon Voyage” from where I expect the Deck nodes to be drawed. I set the “Bon Voyage” page with $Deck(/me)=“shipboard” and each of the 4 deck notes have “shipboard” in their Deck attribute field.

Sadly, it’s not working. My “Bon Voyage” just sits there and links to nowhere on hitting Enter.

I know there might be some “yikes” on my way, but I also hope that this perhaps starts some exchange of working Storyspace files for sculptural hypertext. Mine, so far, is not working.

P.S The “me” file is showing “shipboard” as an active deck which is even more puzzling.

The file:


Your file seems to work OK, but you need to be ‘read’ mode, not ‘edit’ - which is the mode set when i open the file. The read/edit modes are toggled at the top of the text pane.

Thank you Mark,

I’m not sure it is a question of edit mode being on or off. When you open this file in Storyspace reader it goes to read mode automatically. I can of course upload it with read mode switched on below, but my problem is still there.

This file does not work OK, because from “Bon Voyage” you cannot go anywhere, although I think I tried to set it to pull nodes from “shipboard” deck. I’d like the Deck function to work, but here it does not. Once again, the aim of my exercise was to recreate the short tutorial below from Mark Bernstein’s “Getting Started”:

"The initial note named Bon Voyage sets $Deck(/ me)=“shipboard”. Bon Voyage has no outbound links, but because $Deck(/me) is “shipboard”, trying to follow the default link om Bon Voyage will cause Storyspace to randomly select one unread note which is marked as having a $Deck that contains “shipboard”. "


No, it works as advertised for me. So:

  • Open file, select read mode
  • Select ‘Bon Voyage’.
  • Press Return key (to follow the default link**) or click anywhere in the text pane of the app window except on a text link in the note’s text.
  • You move to one of the 4 notes in the ‘deck’ of ‘shipboard’ notes.

** You don’t see these links as they are implied by/calculated from the deck in use. IOW there’s nothing visible in ‘Bon Voyage’ on which to click. you could add text and links but that’s not as per the tutorial you describe.

Try the Return key, and clicking (mouse or trackpad) in the text pane. In fact, doing the latter seems to trump the former!

Edit: updated (in italics, in the light of further testing and my post below).

Strange, it just does not work here. Pressing enter and do not get anywhere from Bon Voyage. perhaps someone could share their own small file where Deck works as intended? Would much appreciate.

Hmm. I may have misinterpreted my earlier actions. Here is how Help describes things:

Read mode lets you explore the hypertext. Clicking in a text link will follow that text link. Clicking elsewhere will follow the highest-priority basic link, often called the default link. Because guard fields may disable some links and enable others, the same writing space may have different default links at different points in the reading.

When the text pane is active, pressing [Return] also follows the default link.

I suspect the problem is you are clicking in the Map, when you should be clicking in the (right-side) text pane. Clicking an item in the map simple sets focus on the clicked item. It doesn’t trigger any link logic. I don’t think that’s very clearly stated in the Help (as quoted above).

In the new style v3 UI, clicking in a note’s text pane is more natural than trying to use the keys.

Default link choice: basic or ‘Calligraphic’ links, i.e. explicit note-to-note links as you see drawn as link lines on the map, always trump ‘sculptural’ (deck-type) links where both are present. Thus to have a node like ‘Bon Voyage’ you don’t want any basic links.

However, if you click on a text link (i.e. a link anchored on a section of the note’s text) this pre-empts the default link. IOW, clicking anywhere in a note’s text pane except on text link invokes the behaviour above.

Does that help?

It does not work for me, either – not in Storyspace or in Storyspace Reader. Following @mwra’s instructions for Storyspace. (Reader is read mode by definition.) FWIW, I’m using a 2017 MacBook Pro 15", in case there is a keyboard-specific issue.

To begin, we enter READ mode and choose COVER PAGE from the Note menu. This resets the $Deck and the visit counts.

a: Enter goes to Bon Voyage
b: Enter does not go anywhere (new issue logged), but clicking anywhere in the text window will go to one of the voyages.
c: Clicking anywhere in the text window will go to a different voyage
d: This continues until every voyage has been visited once. Then, we go to some randomly-chosen voyage.

Update: The correct behavior of the Return key will return in the next backstage release.