Tinderbox Forum

Solved: Time to Edit Post

I accidentally deleted a post and I figured out how. I tried to edit a post that was only a few minutes old.

Step 1: without looking clicked to edit post

I was expecting the edit button, but I go the three dots.

Screen Shot 2020-03-07 at 4.47.36 PM

Step 2: Hit delete by accident

I would suggest lengthening the amount of time a person can edit their post-- even allowing it to “forever” so a user can create an update in their top level post saying it is solved or share a link to whatever solved their original questions.

The settings are under admin/settings if this seems like a good change.


I’ve just tried editing a two-week old post and it worked without any problem.

It’s the pencil icon below the post – does your account not give you one of those? I don’t think my account has any special privileges.

This is the pencil icon:

It may be (buried in the forum config settings) that to edit you need to meet [qualifying criteria]. No spare time to go spelunking right now but i’ll bear this in mind.

† Time since registration, time since post, number of posts, etc.

I’ve seen that “you don’t have permission…” message when I have tried to delete the first note in a thread I started, after other readers have replied to the thread. So, in that case it’s a safety that the thread-originator doesn’t lead the thread headless, I suppose.

It may also be a considered setting by the Discourse devs against the drive-by spam of joining, posting a harmless thing then returning on a second pass to add lots of spam. Of course, this bites the honest members of the forum too. On more thing for my forum to-do list!

Yesterday, the pencil was gone on all of my posts. It is back today. Maybe it was a weird quirk or user error. I use Discourse a lot on several sites and I’ve never encountered that. Oh well, all good now.

yesterday: no edit pencil


today: pencil

Screen Shot 2020-03-08 at 7.53.42 AM