Tinderbox Forum

Strange behavior - losing a note after deleting empty bullet point

In a note I created a bullet list. The last bullet is empty, therefore, I highlighted the row and hit the del-button. Not just the last bullet disappears - the whole note is gone.

I have created a short video to demonstrate, but I cannot upload the video to the forum.

Perhaps I do something wrong?

I think the forum setting don’t allow uploads by first-time posters. If necessary just upload it to your own webspace and link.

i tried following your steps. I made a new docwith one note. added some text then used the text ruler to add an RTTF-style bulleted list. I added one bullet and pressed Return to add a new blank bullet. I tried both forms of ‘delete’

  • If I hit the Backspace key, the new bullet item is deleted and the cursor sits at the left margin on a new line.
  • If I hit the Delete key (i.e. forward delete) nothing happens and the cursor stays in situ.

Other things to check, absent a movie to clarify:

  • does this happen only in this note, or in all notes?
  • does this happen repeatably in all documents or only your test document?
  • does the effect re-occur if you close/re-open the app & doc?

Note that UNTITLED notes with no text are automatically deleted when you move away in many circumstances; Tinderbox here is assuming that you changed your mind.

I have uploaded the video as last post to saschadonath.de. Perhaps this makes things easier. I happened a couple of times before, but I never bothered to make a short clip.

v7.5.6, OS 10.14.1 (dark mode), MBAir 2013
Interesting. Having viewed @elltee’s video I tried my test again and the ⌫ (Backspace) delete key works correctly. Odd, as I think I’m replicating the scenario. As I had a single note in a new file, I tried the following as possible triggers:

  • Saved the file, re-opened. Backspace still works as expected. So not a case of unsaved vs saved file.
  • Added extra notes and selected one of those before trying the note with the list. No change. So, trigger may not require a note selection change beforehand.

Anyway, I’ve uploaded my small test file here, delete test.tbx (57.7 KB), so others can try it and see if the effect is file specific or install specific.

This turns out to hinge specifically on selecting a line by clicking in the left margin — as opposed to selecting the line by triple-clicking, or by click-drag, or perhaps in some other way.

I’m pretty confident we’ll have this cleared up in the next backstage release. It’s an odd corner of the plumbing.

Thank you all for your quick reply.

I was suspecting that this behavior is limited to just a few specific circumstances. I have the feeling that you have a grasp on this topic. Until it is fixed I will refrain from deleting empty bulleted lines and do it differently.

Again, thank you all.

Confirmation if needed. If click specifically in the left margin of the blank bullet line in my text file I do indeed see the previously described behaviour.

Or, delete the empty bulleted line by

  • Placing the insertion point to the right of the bullet
  • Press delete to remove the bullet
  • Press delete again to delete the line

OK: this has been solved.

The problem arose when (a) selecting text by clicking or double-clicking the margin of the text window, if (b) you had not previously been working in the text pane.

This will be addressed in b341 and in the next release. The workaround is to select the text some other way, or to click in the text pane before using the margin to select a line.

1 Like