Tinderbox Forum

Strange folding behavior when applying stamp

When applying a stamp in Outline View, the outline collapses. Sometimes the collapse is only up to the parent; other times it goes even higher in the outline hierarchy. It is a strange behavior most easily described with a video (here). I also attach the test TBX document. Note that the collapsing effect stops once the outline is re-expanded, but the odd behavior reoccurs upon creating new children. Am I doing something wrong with defining and applying stamps?

testfile.tbx (78.3 KB)

TBX v.8.8.0
Note to future readers: link to video file will expire

Oddly, I cannot reproduce this.

Clearly this is a mistake, though I expect it’s specifically tied to changing the key attributes table.

Using the current release (v8.8.0b479) on macOS 10.14.6, I can’t see this using your text file. I’ve tried both the stamps in the document, using the Stamps menu to apply them.

I am on macOS 10.15.6. Same TBX version as your setup.

I’m baffled. It’s not the TBX file because neither @mwra nor @eastgate can reproduce it. Since I see the same issue in different TBX files, it suggests that the issue is at the level of the app or higher (e.g., OS).

Is it a reasonable hypothesis to think that stamps interact adversely with some other app I am using? I am speculating (wildly) that stamp execution triggers a keystroke or a menu selection equivalent to collapse outline. I don’t code apps and cannot gauge whether such inter-app interactions are possible.

How are you using the stamps? The Stamps Inspector? The Stamps menu? Action code stamp()? Some other method?

If might help to know, if only to discount other factors. Also do you have any automation apps, Keyboard Maestro and such, that might perhaps be (unwittingly) in the mix?

Interesting: I tried the Stamps Inspector by selecting the stamp and choosing “Apply”, and surprisingly, no problem.

I normally run from Stamps menu, either by mouse or by using a keyboard shortcut that I define in the name of the stamp. Both methods give the folding problem.

I quit Keyboard Maestro, Textexpander, Moom… no luck there.

Thanks, that difference must have some pertinence. Hopefully it will give @eastgate some hint as to what might be happening. Just because it doesn’t happen on everyone’s system simply gives us a scope - it doesn’t mean you’re not seeing it.

From your last I’m guessing there may be a misdirected shortcut. Use my reverse-look-up shortcut mapping might help you check if you are using shortcuts that collapse the outline.

If possible, create a new user account on your computer. Then try the issue there. If you have no issue in the new account, there’s a good probability that some application other than Tinderbox is interfering with the operation of Tinderbox.

1 Like

@PaulWalters, followed your good suggestion. Remarkably, the problem persists even in a brand-new account!

The behavior is very consistent. The minimal steps to trigger the problem are the same in the new account as in my usual user account:
Open Tinderbox. Go to Outline tab of the initial blank document. Create a first-level note. Make 3 second-level notes. Make a stamp ($Color = "red") named red. Select one of the second-level notes and activate the stamp from the menu. Whoosh. Outline collapses!

At this point, I am more stunned than annoyed by this peculiar behavior.

I should say that this is not a new phenomenon. I’ve just learned to live with its quirky behavior, but life would be good if I didn’t have to unfold an outline every time I apply a stamp.

I will continue to investigate and report back if any new observations turn up and most definitely if the situation resolves.

Sorry, not here.

(I know it’s annoying that there’s no confirmation of the report. Sorry.)

From the feedback, this appears to be a real but localized problem. I will follow up via email to Eastgate. Meanwhile, an update: neither booting in safe mode nor resetting PRAM fixes the issue. Very odd.

Separately, following @mwra suggestion, I consulted the reverse look-up table for entries involving outline-folding. It mentions:

Right Arrow: Select First Child (Outline & Chart)

Indeed, right arrow performs as advertised when the selected note is a parent. However, if the note has no children, tapping right arrow folds the branch. The selected note with its siblings are folded under their parent. If this is normal behavior, perhaps an edit to the reverse look-up table is warranted; if the behavior is unusual, add it to my growing list (and possibly related to the Stamp menu-selection behavior).

I suspect the behaviour is intentional and certainly makes sense, as → also expands a selected closed container.

I’m not a keyboard-only user so such niche usage is something I’ve not tripped over (unless I’ve seen it documented elsewhere). But for many people only using keys (where possible) needs this kind of nuance. I can add it it to my docs.

These steps produce the behavior you describe on my machine. However, it only works the first time I apply the stamp. If I apply the stamp, then reopen the collapsed container and apply the stamp to a different child, the note container doesn’t collapse.

For what it’s worth, without closing the doc, I then created a new container with children and applied the stamp to one of these children. Once again, the container collapses, but again, only the first time I apply a stamp to one of its children. This matches the description from the OP.

yes, I see precisely the same additional phenotypes @bcrane reports.