Tinderbox Forum

Timeline Labels Not Displaying

Symptom: Can’t get the Timeline Labels to appear in the Timeline when set with attributes

I’ve been having trouble getting the timeline labels to appear on the timeline.

In my experiments I suspected I was creating some type of conflict and removed everything in a test file except

  • a container
  • A couple of events in the container
  • Prototype - Event

Each event has a TimelineBand allocated.
In the container I set TimelineBandLabels

With this setting no labels appear on the timeline.

Next:
on the Time Line display I click and open "Change Settings’. In the field titled Labels I type the names of the bands, separated with semicolons. This makes the band labels appear.

Any suggestions as the why the attributes TimelIneBand doesn’t appear to be working.

Note: this is happening in TB 9.0.0

Thanks

The labels are showing up for me in TB 9.0.

Like @sumnerg, bands and band labels work OK for me. Could you post a small TBX that shows the problem? That way we can test if it is a problem local to you, a misconfiguration issue or something else.

Thanks for the responses.

File is attached.

Test Case for Timeline.tbx (92.3 KB)

The issue is that you’ve set the Band Labels in note ‘Chronology’, but—as the Timeline view tab label shows—you Timeline view is looking at the whole document as opposed to the descendants of ‘Chronology’.

Try this with your file:

  • Make a new tab using the ‘+’ sign.
  • Set the tab to Outline view (right-click the new tab and use the pop-up menu)
  • Double-click the note icon for ‘Chronology’ to make it the view root - you’ll see a breadcrumb trail appear. Note the change in name on the tab to ‘Outline: Chronology’ not ‘Outline: Test Case for Timeline’
  • Change this tab to timeline view. Tab label is now ‘Timeline: Chronology’

You band labels now appear! This is because we are at the right scope so the timeline view settings you put into ‘Chronology’ are being used. In your sample file, as posted, the timeline view is using the document root setting, i.e. the doc defaults. The doc default for $TimelineBandLabels is "", i.e. no value. thus in your original test you see no labels.

I think the missing part of the setup here is understanding what container is the current ‘root’ of your timeline view. Obvious after the fact, but not so much before. I’ve made a mental note to try and address this in my notes.

@mwra

Thanks for this (and all your other) excellent help and support. I just want to acknowledge that your time like everyone else’s is valuable and so I appreciate the help in solving my problems.

I had incorrectly assumed that the “Timeline” must also encompass the whole document.

Problem solved and all working perfectly.

Ironically, without some set-up it does! Nonetheless, I’m glad you’re fixed and thanks for the kind words.