Tinderbox Forum

Bold Not Working

I’ve noticed that bolding note titles no longer works in my documents. Anyone else seen this? Here’s an example in a new file.

At first I try ⌘B and nothing happens. Then I try ⌘I to show that italics still works. Then I try toggling “Bold” (nothing happens) and then I tick “Strikethrough” and you can see that works.

Running Tinderbox Version 8.9.1 (b486) on macOS 11.2.1 (20D74)

Curious!

Ha! I just came to the forums to report this…

What I’m noticing all of a sudden is that Bolding is disabled within notes.
If I’m typing in a note and Do the Cmd-B, the computer pings in complaint.
If I right-click selected text and pick /Font, the “Bold” is grayed out.

It’s probably related to the Theme? Because if I change the default font of notes in the Document Settings, I can get my bolding back.

The Default font of Notes appears to be set to MercurySSm-Book 16pt. Is this the default set at the factory?
Lastly - I thought I knew this but have forgotten - how does one set a different startup default font for all documents in Tinderbox? I searched on the forums but couldn’t see a specific answer, other than something to do with editing the config.xml, which then seemed to be not recommended (I got the feeling).

If I’ve modified something font-wise, I didn’t do it intentionally and would be happy to “reset” to get bolding back. Is there a way to test this?

  1. Not all fonts have bold faces.

  2. It’s possible (though unlikely) for the bold face of a font to have been damaged in a disk mishap, and require reinstallation.

  3. What font were you using before you changed it in Document Settings?

  4. There’s currently not a way to change the default font for all documents. But, if you wanted to, you could change the font specified by the default color schemes by editing them and saving them in the color schemes folder in the support folder.

  5. But it’s probably easier to (a) use a stationery pad set up the way you prefer when you make new documents, or (b) just save your favorite settings as a color scheme, and keep the color scheme file ready to hand.

Why don’t you email me the mysteriously timid file?

Oh derr. Turns out I don’t have MercurySSM on my Mac. That’s probably what it is.

As I don’t necessarily want to purchase it, is there anyway we could change the default font to a free/Mac-supplied one? Really not great with opening templates. I like to hit Cmd-New and start typing.

Same issue with title - it’s set to RingsideCondensedSSm, which I also do not own.

Interesting! I don’t have Mercury either (assume searching Font Book is the way to tell).

Also here are my document settings (I don’t recall changing them):

FWIW, I can’t replicate the title non-bolding issue on v8.9.2 (macOS 10.14.6).

For @archurhh, the current font-type attributes are listed here. The respective, linked, articles describe the current (v8.9.2) defaults. Only $TextFont and $NameFont via doc settings can be set via Doc settings; the other 9 Font-type system attributes can be set via the Document inspector.

1 Like

And FWIW, this used to work fine for me.

Thanks @mwra - the issue is that MercurySSm basic costs $199 from Hoefler and Co. And the Ringside font set ranges from $250 to $999. As I’ll never be using them, I’d much rather have a default fontset that I can run with.

Back in Tinderbox 6.x, the default text font used to be HoeflerText Regular, which suited me just fine.

Mercury and Ideal are supplied by the app. In the app pckage (Tinderbox 8/Contents/resources/Fonts/ are 71 font files including various faces for: ArcherSSm, Decimal, IdealSansSSm, MercurySSm, RingsideCondensedSSm, Sketchnote and Tungsten.

The only Font-type system attribute not using a Tinderbox supplied font is $CodeFont, which uses Courier New. The legacy (pre-v6) $TitleFont used Lucida Grande. Otherwise all font attributes use one of the above.

2 Likes

@archurhh, there is no ‘MercurySSm’ as such. Tinderbox installs (provides?) the following faces for the ‘MercurySSm’ family:

‘MercurySSm-Book’ is the face used for default $TextFont.

Are you using a non-default font handling app on your system, such as may be used if doing a lot of graphic design? Such a tool might switch off some of the available fonts.

I’m not sure how Tinderbox adds or makes available its built-in fonts, that’s a question for @eastgate.

1 Like

MercurySS is basically a sub-family (SS stands for Screen Smart)

I’m not using any 3rd party font manager. Have done a ton of work in fonts/typography in the past, and though rusty, have a decent idea of things on my side. I think there’s some issue here, and am keen to be proved incorrect.

I see the .otf font resources in the /resources/fonts/ folder thanks. But the issue persists - I cannot get either the title or the text of a note to bold, UNLESS I change either the font of that selected text or change the Document’s default font.

I even did a quick and dirty and installed the .otf’s in Font Book so I can be assured the system sees the fonts. Sure enough, it does. The fonts can now be used in multiple apps. But still, even in other apps, Mercury doesn’t bold, while Ringside does.

1 Like

Both Mercury and Ringside are built-in to Tinderbox and are (or should be) available within Tinderbox.

1 Like

Mark there is definitely something going on here I can’t suss. Happy to take it offline with you and keep forum chatter down.

Bold doesn’t work here either, on a brand new Tinderbox file with no configuration (i.e. $NameFont is IdealSansSM-Book). $NameBold changes, but the font itself stays stubbornly timid.

It does work with Courier Prime, though, so it looks like it’s an issue with IdealSansSM-Book.

To be precise:

  1. You can change to Bold font by selecting IdealSansSM-Book in the Apple Font dialogue (double click on the Attribute NameFont), but cmd-B or toggling NameBold doesn’t work.

  2. Courier Prime works as expected for both manual selection and toggling NameBold or cmd-B.

…and Arial and Helvetica, the two I just tried.

1 Like

Mark,

Of that list of fonts (the ones in your post, not the full 71…) only Archer works with cmd-B / toggling $NameBold. The rest just ping… (You can still select bold versions manually through cmd-T, but doing so doesn’t toggle $NameBold, as it does with non-Tinderbox fonts such as Courier Prime etc)

1 Like

I find that with the Note Text - I can select Bold from the Font Menu (Cmd-T), but NOT from the right-click contextual mini pop-up menu, and not by selecting the text and pressing Cmd-B.

With the Title, the issue is different - WHATEVER font I choose, the visual appearance of the Title remains unchanged.