Tinderbox Forum

Export map view

Hello, I would like to export map view of a file from tinderbox. In fact, I have created process flow (of a functionality to be developed) in map view. I wish to share it with my development team. Is there any way to export the process flow in map view? Thanks

There is currently no HTML-type way to do this. You can use Edit menu -> Copy View as Image. this takes a vector-based image of the whole map, not just what is on screen. It captures pretty much all** of the visual customisation of the map view. Of course it doesn’t capture all the notes, but just the map view (left pane).

** a few of the more complex subtle things may get missed. I don’t have a list before anyone asks.

As the image is vector, if you save it as a PDF is will scale pretty nicely.

Exporting map view would be great and is a very old feature request. At present it’s being drowned out by the call from those who want sync-everywhere. Certainly, Not having export to some form of non-OS-specific form such as a web browser (HTML? SVG?) is a sadness IMO as it would allow leverage of so much more value from maps. The issue is not exporting the note (text, attributes, etc.) data but the map itself. I think it requires some work at the app end. I last tried this back in 2009 and there were issues getting the size/scale of things right (even without trying link lines) but browsers and web-facing graphic libraries have moved a long way since.

1 Like

Hello Mark, Thanks for your answer. I could see copy view as an image. I tried pasting it into apple notes. I see although all the tinderbox notes have been pasted but the arrows connecting and remarks (as agreed, disagreed) are missing. Is there any way to get the full image with arrows and remarks too? Do you suggest any other place to paste? Thanks again.

When I “copy view as image” I get the map and all links and adornments, badges, etc. In other words, WISIWIG.

What do you mean by “remarks” – that’s generally not a term for something in the Tinderbox interface.

I presume you mean the link type labels, drawn somewhere along the link line in the map? If so, I do see them. Try setting your map to ‘original size’ zoom and then copy the image - note Tinderbox will include the bits of map off-screen. I’ve a hunch you may have zoomed out to see more map and at that scale the font calculations might cause the exported to omit the link label. If a copy at normal zoom doesn’t work I wonder if it’s some font issue. Anyway, it should work.

Sorry, re pasting. If busy and/or not familiar with graphics apps, open Preview and use file -> New from clipboard. Saving the result as a PDF preserves the vector (scalable data). Saving as a PNG will rasterise it turn it into a bitmap that will pixellate at high zoom levels.

1 Like

Thanks, I sincerely appreciate your help. Yes, I mean link type labels by remarks. Is the ‘original size’ zoom same as standard size (viz command O)? I tried doing at the standard size, but the problem persists. The problem is that I can’t view link type labels and link line in the exported map. Thanks again.

The font is IdealSansSSm-Book-14pt. Interior scale is 1.50;

Ok, well here’s what I see in a simple test:


It check the Links Inspector check each link type your using on the map:


If ‘visible’ is unticked the link line won’t be drawn, and if ‘labeled’ is unticked even if the link is drawn the label won’t be even though the link still is of that link type in all other respects (e.g. for action code, in dialogs, etc.)

Does the problem affect all TBXs on your system, or just one/some TBX files? This is an important factor to help pin down the issue.

Assuming the Links Inspector is correctly configured, if you still have the problem could you upload or post a link to a small TBX that displays the problem. Please include in the TBX a note summarising the problem as you experience it.

Please find the jpg attached

You would see that some notes are connected whereas others are not. Similarly, some have link labels, and some don’t have it. Thanks

Thanks. Is this JPEG the exported map image. Could you take a screen grab of part of the map showing info that isn’t making it to the exported image. Seeing the size of the map, I do wonder if - especially if there are very many links - whether the export process is overloading. There is no hard limit but very big maps with many many links eventually overload (no technical term!0 the drawing process.

Thanks for your response. Yes, it is the JPEG of the exported map image. Please view the gif of the map at https://cl.ly/013Y0i3V0Z23 Thanks

Here is the screenshot of some portion the links of which do not reflect in the map exported. https://cl.ly/0P2r412p311g

Aha. It looks like the missing data is all the orange-red coloured links, which looks suspiciously like the ‘undefined colour’ colour value. There was a now-fixed issue a while back where new link types were getting allotted this colour.

My recollection is the latter was fixed but it may be the user needs to first (re-)set the link type colour.

Try this:

  1. Open the Links Inspector.
  2. Select each link type in turn and look at the colour chip on the Inspector. If is is the above orange-red colour either use the colour pop-up to set the predefined colour ‘black’ or set black or #000000 via the colour chip.
  3. Check the new link colours show on the map
  4. Export an image and check.

If the links/labels are now there, the issue was the previous glitch not being retro-actively fixed. If you wanted some different colour you can now re-edit the links to use a colour using the same controls as above.

If still no joy I suggest sending the TBX (zip first, if large) and emailing it to Tinderbox support (info@eastgate.com).

I have changed the color to black. But still the same problem persists.

OK, then I think you now need to contact support. We users simply can’t see deeper into the app than the controls I’ve already discussed.

Copy View as Image is mistakenly omitting links outside the window viewport. Hence, modest tests export correctly, but the big (!) map doesn’t. We’re working on a fix.


Thankyou for your kind help

The current backstage release corrects the problem, as will the next public update.