Tinderbox Forum

Prototypes: just plain stuck

Good morning,
I’ve created a “pType_Journal Article” note with all the necessary reference attributes.

I then create another note and make its prototype “pType_Journal Article”.

However, I cannot figure out how to view its list of key attributes inherited from “pType_Journal Article” so that I can change a reference page number, etc.

Thank you for any guidance.


OK if you see no key attributes table, first check you’ve not folded it away:

The control indicated shows/hides the KA table. Next, you see the KA table but the list of attributes (not attribute values) isn’t the same as in the prototype note. This will be because you’ve customised the table (stored in $KeyAttributes) so it doesn’t inherit the prototype’s $KeyAttributes and thus table contents. See about resetting inheritance; that is just one way to do the task, buy all means use the quickstamp Inspector if you prefer.

Now, you see the right attributes lists but the wrong values. It’s the same problem as above, as some/all of the note’s attributes listed in the KA table have values set locally in the note and thus over-riding inheritance. As above re-set the attributes.

For an action code way to do this see here.

You might also want to check these more general tutorials on inheritance, setting prototypes, and setting KAs.

I see now. For some reason the note I created did not have that triangle button. Subsequent notes I’ve created and assigned the p_JournalArticle prototype do have that button and I can see the key attributes inherited from the prototype note.

Thanks Mark.

1 Like

I am having a similar issue. I got the prototype to work for one note, but when I select if for subsequent notes, it displays the name of the prototype, but does not carry with it the key attributes (as it did the first time I tried it). I looked at the linked tutorial but still do not understand what steps I am missing. I want most of my notes to automatically have the same few fields to fill-in, or at least to be able to choose a prototype that effectively does that.

1 Like

Possibly you have set some Key Attributes in a note or notes and broken the inheritance between the Key Attributes setting in the prototype and the local settings in your note or notes.

Select the affected notes. Open the Inspector. In the Properties Inspector, choose the Quickstamp tool (second tab), then locate the KeyAttributes attribute in the TextFormat group. (1) Click the “default” button, and (2) press “Apply”.

In the image, “default” means the Key Attributes that the note(s) inherit from the prototype, which are shown immediately below. “Assigned to this note” are the Key Attributes set within this note locally.

Then go back and re-review the Mark Anderson’s reply, above, and the tutorials.

1 Like

Thank you, Paul - will try this!

I’m having the same problem - the flippy triangle does not appear.
my workaround is just putting the citation information in the body of the note but it’s frustrating.

More detail please! That sounds wrong: can you provide step by step instructions to reproduce this in a new file? If not, it is likely the problem is im just one file.

Either way, this should work.

In addition to @mwra’s request, could you post a screen shot of Tinderbox on your computer?