Returning to Map view with all Notes completely out of view

Going absolutely berzerk with the main TB Map view.

Every single time I leave the Map view (go to other views and back, re-opening, etc.), it shows a view with nothing visible and all my notes entirely way off view. I have to pan way over to get to them again. I cannot begin to tell you how utterly annoying this is. Candidly, to the point that I am about to give up on my trial. I’ve gone through most of the awesome tutorials, most of the incredible videos, the fantastic TBx Ref docs, and done some very advanced things to understand all aspects of TB during the trial. I am a very techy power user of thousands of sites/apps over the years, including creating them, so trust me, this is not a “user error”. :wink:

But this simple UX issue has me at my wit’s end. I’ve tried moving the notes to the upper left corner (and other places), and it just seems to make things worse. I found these two articles:

…and they appear to get at the issue. But are either closed, referring to fixes in later releases, or do not give solutions. I am on TB version 9.5.1., the latest, and I see no fixes for this.

Please help straighten me out! And aside, if there is some workaround or resetting of attributes to fix this, great. That will save me, and I am all in on this amazing tool. BUT IMHO, if you don’t want other new users to bang their heads against the wall for days, I’d suggest adding some “Reset Window” menu command or something to resolve.

This happens to me, as well, but only in one specific TBX file, which I’ve attached. In the TBX files where I manage my tasks, I don’t see the same behaviour.

DEVONthink Visualization.tbx (788.2 KB)

Here is my TBX file as well, Essentially,

  • open it (notes till be gone out of view)
  • drag the notes to within view
  • click Outline View
  • click back to Map View (notes will be gone and out of view yet again.

ScoreOnScore.tbx (258.6 KB)

Thanks for any help! :slight_smile:

  1. I scrolled the notes into view.
  2. I moved one note just a bit, to tell Tinderbox that something has changed.
  3. I saved the file. Seems to be fine now!

ScoreOnScore.tbx (308.7 KB)

@eastgate Thank you for replying.

I tried that and a zillion other things many times, and nothing worked.

Nonetheless, I downloaded your version, opened it, and it behaves the exact same “wrong” way for me. Even when I first open it, all the notes are out of view. I move them in view, switch to Outline and back, and they are back out of view.

Other thoughts? Happy to do a screenshare if you’d like to get to the bottom of this.

If it helps, here is what I see when I reopen the file every time, OR change to Outline and Back:

As you can see by the scrollbars, it has jumped to the bottom right-hand corner of the view where there is nothing. I have to pan all the way back up to the upper lefthand corner. But again, that makes no difference. It just goes back to the bottom right again when I go out and come back.

It seems to me that the canvas (or whatever you call it in your world) is enormous for whatever reason. Possibly because I tried to fix this issue repeatedly by dragging all the items within view toward the upper left. I’ve noticed the scroll bars change, as though TBX is making the canvas even bigger for whatever reason. Perhaps you are constantly adding back in some “margin” or something every time a user has dragged to the edge? That just exacerbates the problem.

I would think:

  1. Don’t add a canvas margin just because the user wants an item closer to the left or upper, or both.
  2. Certainly, don’t default open all Map views to the lower right-hand corner of the canvas every time.
  3. Defaul to the previous view of that Map that the user was last in, or at a minimum open a canvas to the upper left corner (where content is likely to be) instead of the lower right. Or even add a user setting where they can choose one or the other.
  4. Offer some sort of “Trim canvas” or “Trim Note View” command that clears all the wasted space around the actual content.

That said, why would it work for you but not me? Do you have some advanced version, or are there user settings somewhere affecting behavior?

Thanks. Hope some of this helps.

Just opened the repaired version. Here’s what I see:

You will observe that all your notes, for some reason, are quite distant from the origin. srMLBSeasons is {-10.36, -43.76}. All canvases include the origin, IIRC. So it’s a big canvas. Still, as you see, I do open where I left things.

I don’t know what to say; when I open the file you sent me, I do not see the same thing. Even if I expand the note to the full size of my 3840x2160 monitor. They never appear within view when I come back to the view. I have to pan every time.

This makes sense. Did you read what I offered after the screenshot I provided? It explains how the canvas got so big trying to get these back into view.

Again, simply not doing that for me. And is it designed to open “where you left it,” or with the origin centered? Seems more like the latter.

At this point, I need to move on, as I’ve wasted dozens of hours on this issue. Can you please

  1. Let me know how to either reset the origin, trim the canvas size back down, or do something to fix this? Everything I’ve done the past week just makes it bigger and causes me to have to pan more and more. I tried copy/paste to a new TBX, and it just crashed.
  2. What can I do to avoid this in the future?

Thanks much. I LOVE the power of this incredible software. If I can just get past this UX issue…

For what it’s worth, I downloaded @gregfay’s file, and I’m seeing the same behaviour he is, but only if I close the TBX file and reopen it. If I switch to the outline tab and back to the map view, the map is still where it should be. If I then save the file, close it, and re-open it, the map view jumps to the bottom right-hand corner of the view where there is nothing.

Edit: Actually, the map view does jump to the bottom right-hand corner if I go into a container and then go back to the root map view.

Edit 2: I’m on 9.5.2 (b606) and macOS 13.1.

@ebarstad Thanks, Eric, for confirming I’m not the only one seeing this. (Per other threads, others have as well.)

I just downloaded your file and do also see the same issue with that one as well. I think we are getting somewhere in that this UX issue causes us to try to correct it by moving content. And with the evidently auto-expanding margins, matters get worse and worse as the canvas gets bigger and bigger.

We need some way to trim the canvas back down to the content size when this happens. And remember what the last viewing virtual window was instead of going back to the lower right-hand corner every time (which I believe in reality it may be centering on the canvas, forcing the scrollbars down).

I just upgraded from 9.5.1 → 9.5.2, and confirmed that did not help.
I am on MacOS 12.6.3.

Edit: I did find this article from TBxRef:

It does not appear that this statement is true with version 9.5.2 from what we are seeing:

If a map view of a note is closed and later reopened, it will scroll to that map’s most recently viewed position.

Send your file to tech support:

Your impression of how the canvas (as you call it) works is incorrect. I’m late for a concert, so that’s going to have to be enough for now.

1 Like

@eastgate Understood. I figured…just was trying to provide some thoughts. Something is up, nonetheless. I’ll shoot 'er off to tech support as you suggested. Thanks for your help, and enjoy the show!

There is definitely something odd about your file. I think—noting I’m just a fellow user, so can’t see inside the app—that you’re _unintentionally triggering some edge case.

A new TBX opens with the map {0,0} location on the left margin and a bit down from the top of the view:

Why not in the corner? I’ve no idea. Anyway, your file’s top left content starts way off {0,0}. To be clear, that no wrong, even if unexpected:

If I select all map content and move it closer to {0,0} and save, close, re-open the TBX, the content opens on screen. Based on that my hunch is that if the content is too far from the centre of the map the app is centring on the default start map position. Again, why, I don’t know but a possibility is the app is dealing with the (perceived) result of some different potential positioning problem but to the bad effect seen here.

The nature of such problem is the app doesn’t tell you the data isn’t where expected, so why would you move it (as you might if asked).

Separately, you’ve a number of misconceptions about ‘views’ but I’ll address those in a separate post, as they may be adding to your confusion.

@mwra Wow, “the” Mark Anderson. I’m honored!! :slight_smile:

Now that I know you’re right-click position-viewing trick, I see that reopening mine does open it with {0,0} near the upper right corner.

But for the life of me, I can’t move the selected content to near {0,0} as you were able to. I can get it closer in the X-axis, but the Y-axis always resets to around -20 or much more when I get closer to 0. All this does is make things worse with my file. When I close it and reopen it now, it’s still way off at this location (which I guess is similar to yours):

It is in support now, so I’ll refer them to your comments in this thread. Hopefully, I can get this resolved so I can forge ahead. It has simply been too difficult to work with so far.

Thank you!

@mwra Aside, I tried to explain in the thread how I “think” I caused it, and I still feel that’s it, in case it makes any sense based on your knowledge.

Not sure if that’s it, but it sure does seem like it keeps padding in more and more margin (padding around content) as you get close to the upper left edges.

Two things I’d look for:

  1. Can you create a new project - similar Notes and Containers - and have it behave similarly?
    (Also try copying all current content from this misbehaving project into a new project, for kicks)

  2. Have you been making any root-level changes during this time? Any relocating of, or creating Notes at the root level? Even in Outline View, or via Agents/Actions?

  3. Are you using a custom Theme? Light or Dark Mode?

I’ve had, and resolved, this. But that’s all I can think of rn. Will download your file and play with it tomorrow (winding down here; 1:30 am, Dire Straits playing Your Latest Trick).

First, re:

I just realized @eastgate is you, Mark Bernstein, the maker of this fantastic creation! So apologies; if you say my thinking of the “canvas” is incorrect, I absolutely believe you! :wink: If it helps, I felt like it was adding more margin (padding) because as I moved content to the upper left (to try to fix this), it kept moving the content back over, showing new space again around it again. I guess the visual of it led me down that path.

So, since I guess I uncovered some sort of bug, some background on this file. I would think this is your typical new user use case. It was my first TBX file, and was used to dabble with all kinds of features based on reading through the manual, @mwra aTbRef docs, and walking through dozens of @satikusala videos to learn all about this before buying (which I eventually did, based on the clear power of this beast). So I tried a lot of things within this file. What you see in the file is what I’ve done. Some prototypes to see how inheritance and system and user variables work, and some agent code in a Rule to set the prototype, colors, and variables to test logic. That said, I have not fiddled with any system variables (other than the clear-cut ones straight from the videos and docs).

@archurhh in response to your questions:

Can you create a new project - similar Notes and Containers - and have it behave similarly

So far, no. Everything seems fine. I’m just trying to be super careful not to move things around to position my viewport of content.

try copying all current content from this misbehaving project into a new project

I had tried this multiple times, and just tried again. I select all, Copy, open a new Tbx document, Paste, and it hangs indefinitely (beach ball). I have to Force Kill the app.

Have you been making any root-level changes during this time? Any relocating of, or creating Notes at the root level? Even in Outline View, or via Agents/Actions?

Yes, I did lots of notes, prototypes, etc., all experimenting at various levels, including the root. I did not get very deep with Agents/Actions; only as far as programmatically setting prototype, color or user attributes.

Are you using a custom Theme? Light or Dark Mode?

No custom. My Mac is in Dark mode, though I do switch back and forth some.

I’ve had, and resolved, this.

I wish I could, but could never figure it out. Am now just rebuilding from scratch. Kinda super paranoid in fact about moving things around too much to position in the viewport, as I am trying to move forward with this actual project (now that I’ve finished my self-training with everyone’s help), and don’t want to break it again.

Dire Straits playing Your Latest Trick

One of my very favs! In fact, just got me to put on that whole awesome album.

That doesn’t chime with my experience of moving notes (as described in my previous post above). But, to be clear, I’m selecting note(s) and moving them across the map so as to alter their map position (i.e. $Xpos and $Ypos actually change).

Understood, and I don’t think anyone is suggesting it is. But, it is unusual and not reproducible for all which suggests you’ve hit some unseen condition with produces an undesirable input. IOW it isn’t a zero-sum game where either user or app must be wrong: it’s perfectly possible, though mis-aligned assumptions for both to be right but for neither to be happy.

It’s unclear here (and I don’t mean this unhelpfully) whether you are dragging the map or the item(s) on the map. Right-clicking on the map background (with no note selected) will indicate where on the map you r items are. If you just drag the map (e.g. click-drag on the background) the X/Y position of content wont change even if they have moved within the view.

I’ve tried @eastgate’s file and I don’t see the content on screen when I open in. But your file reports as made last-using v9.5.1, I’m on v9.5.2 and @eastgate report’s a later version (likely a development beta). I’m unclear if that is a factor.

Re ‘canvas’ vs. ‘map’. on one level they’re just words, but generally the former is most often used to describe a static drawing such as you might make in Photoshop or Illustrator (other drawing apps are available, etc.). By contrast, Tinderbox’s map view is dynamic updating to reflect a whole host of possible changes to underlying attribute values. To a casual glance those two might look the same yet they aren’t. However, the difference matters in terms of the assumptions we make about what we see on screen. Thus a map isn’t a drawing, and I think that’s the gist of @eastgatr’s point. Sorry for the long ex[lain, it’s one of those things that’s obvious once you get the underpinnings but for which there isn’t a simple explanation (IOW, it’s not a case of bad descriptions).

I believe big work’s afoot for something to be demo-ed in tomorrows meet-up and so this issue arrives at an awkward moment. I’ve a suspicion the cause won’t be complex once found but until the test doc works (or doesn’t!) the same fro everyone it can be difficult to get traction on a fix.

Anyway, HTH

OK: this is now understood.

We’re not switching tabs, we’re using ⌘⌥-O to switch to outline, and ⌘⌥-M to switch back to map. In the current implementation, changing the nature of the view doesn’t anticipate changing back: that’s why we have tabs.

Might change in the future.